aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-python/recipes-devtools/python/python-aws-iot-device-sdk-python.inc18
-rw-r--r--meta-python/recipes-devtools/python/python-aws-iot-device-sdk-python_1.1.2.bb2
-rw-r--r--meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.1.2.bb2
3 files changed, 22 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-aws-iot-device-sdk-python.inc b/meta-python/recipes-devtools/python/python-aws-iot-device-sdk-python.inc
new file mode 100644
index 0000000000..a64c6c49ad
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-aws-iot-device-sdk-python.inc
@@ -0,0 +1,18 @@
+DESCRIPTION = "SDK for connecting to AWS IoT using Python."
+HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30"
+
+SRC_URI[md5sum] = "6835982c7fb36b19aa474d346f29ec3d"
+SRC_URI[sha256sum] = "ac98d39d7230e06fc9a30bdb3398c985a7c357b10898a769db022d315855102a"
+
+inherit pypi
+
+PYPI_PACKAGE = "AWSIoTPythonSDK"
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-pyopenssl \
+ ${PYTHON_PN}-json \
+"
+
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta-python/recipes-devtools/python/python-aws-iot-device-sdk-python_1.1.2.bb b/meta-python/recipes-devtools/python/python-aws-iot-device-sdk-python_1.1.2.bb
new file mode 100644
index 0000000000..12ae978e34
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-aws-iot-device-sdk-python_1.1.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools
+require python-aws-iot-device-sdk-python.inc
diff --git a/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.1.2.bb b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.1.2.bb
new file mode 100644
index 0000000000..c43649dbfe
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.1.2.bb
@@ -0,0 +1,2 @@
+inherit setuptools3
+require python-aws-iot-device-sdk-python.inc