aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb')
-rw-r--r--meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb13
1 files changed, 5 insertions, 8 deletions
diff --git a/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb b/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
index 2fa5ec1fb9..5dc3ea6632 100644
--- a/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
+++ b/meta-filesystems/recipes-filesystems/httpfs2-fuse/httpfs2_0.1.5.bb
@@ -1,25 +1,22 @@
SUMMARY = "This is a filesystem client based on the HTTP using FUSE"
HOMEPAGE = "http://httpfs.sourceforge.net"
-LICENSE = "GPLv2"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://debian/copyright;md5=83f224c5182f148ec92e0b9f84b3c6c7"
inherit pkgconfig
DEPENDS += "fuse"
-RDEPENDS_${PN} += "fuse"
+RDEPENDS:${PN} += "fuse"
-SRC_URI += "https://astuteinternet.dl.sourceforge.net/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz"
+SRC_URI += "${SOURCEFORGE_MIRROR}/project/httpfs/httpfs2/httpfs2-${PV}.tar.gz"
SRC_URI[sha256sum] = "01cb4bb38deb344f540da6f1464dc7edbdeb51213ad810b8c9c282c1e17e0fc1"
S = "${WORKDIR}/httpfs2-${PV}"
do_compile() {
- cd ${S}
- oe_runmake httpfs2
+ oe_runmake -C ${S} httpfs2
}
do_install() {
- cd ${S}
- install -d ${D}${bindir}
- install -m 0755 httpfs2 ${D}${bindir}
+ install -Dm 0755 ${S}/httpfs2 ${D}${bindir}/httpfs2
}