aboutsummaryrefslogtreecommitdiffstats
path: root/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb')
-rw-r--r--meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb56
1 files changed, 28 insertions, 28 deletions
diff --git a/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb b/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
index 7f56c88fcc..eb75699cc6 100644
--- a/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
+++ b/meta-filesystems/recipes-filesystems/owfs/owfs_3.2p3.bb
@@ -34,7 +34,7 @@ EXTRA_OECONF = " \
--disable-owperl \
"
-do_install_prepend() {
+do_install:prepend() {
install -d ${D}${sysconfdir}/default/
install -d ${D}${sysconfdir}/init.d/
install -m 0755 ${WORKDIR}/owhttpd ${D}${sysconfdir}/init.d/owhttpd
@@ -43,39 +43,39 @@ do_install_prepend() {
PACKAGES =+ "owftpd owhttpd owserver owshell libowcapi libow libownet owmon owtap"
-DESCRIPTION_owftpd = "Anoymous FTP server for 1-wire access"
-DESCRIPTION_owhttpd = "Tiny webserver for 1-wire control"
-DESCRIPTION_owserver = "Backend server (daemon) for 1-wire control"
-DESCRIPTION_owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
-DESCRIPTION_libowcapi = "easy C-language 1-wire interface "
-DESCRIPTION_libow = "easy C-language 1-wire interface to the owserver protocol"
-DESCRIPTION_libownet = "easy C-language 1-wire interface to the owserver protocol"
-DESCRIPTION_owmon = "Monitor for owserver settings and statistics"
-DESCRIPTION_owtap = "Packet sniffer for the owserver protocol"
+DESCRIPTION:owftpd = "Anoymous FTP server for 1-wire access"
+DESCRIPTION:owhttpd = "Tiny webserver for 1-wire control"
+DESCRIPTION:owserver = "Backend server (daemon) for 1-wire control"
+DESCRIPTION:owshell = "owdir owread owwrite owpresent owget - lightweight owserver access"
+DESCRIPTION:libowcapi = "easy C-language 1-wire interface "
+DESCRIPTION:libow = "easy C-language 1-wire interface to the owserver protocol"
+DESCRIPTION:libownet = "easy C-language 1-wire interface to the owserver protocol"
+DESCRIPTION:owmon = "Monitor for owserver settings and statistics"
+DESCRIPTION:owtap = "Packet sniffer for the owserver protocol"
-FILES_owftpd = "${bindir}/owftpd ${systemd_system_unitdir}/owftpd.service"
-FILES_owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd \
+FILES:owftpd = "${bindir}/owftpd ${systemd_system_unitdir}/owftpd.service"
+FILES:owhttpd = "${bindir}/owhttpd ${sysconfdir}/init.d/owhttpd \
${systemd_system_unitdir}/owhttpd.service"
-FILES_owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver \
+FILES:owserver = "${bindir}/owserver ${sysconfdir}/init.d/owserver \
${systemd_system_unitdir}/owserver.service \
${systemd_system_unitdir}/owserver.socket"
-FILES_owshell = "${bindir}/owread ${bindir}/owwrite \
+FILES:owshell = "${bindir}/owread ${bindir}/owwrite \
${bindir}/owdir ${bindir}/owpresent \
${bindir}/owget ${bindir}/owside"
-FILES_owmon = "${bindir}/owmon"
-FILES_owtap = "${bindir}/owtap"
-FILES_libowcapi = "${libdir}/libowcapi-*"
-FILES_libow = "${libdir}/libow-*"
-FILES_libownet = "${libdir}/libownet-*"
-FILES_${PN} += "${systemd_system_unitdir}/owfs.service"
+FILES:owmon = "${bindir}/owmon"
+FILES:owtap = "${bindir}/owtap"
+FILES:libowcapi = "${libdir}/libowcapi-*"
+FILES:libow = "${libdir}/libow-*"
+FILES:libownet = "${libdir}/libownet-*"
+FILES:${PN} += "${systemd_system_unitdir}/owfs.service"
INITSCRIPT_PACKAGES = "owhttpd owserver"
-INITSCRIPT_NAME_owserver = "owserver"
-INITSCRIPT_NAME_owhttpd = "owhttpd"
-INITSCRIPT_PARAMS_owserver = "defaults 20"
-INITSCRIPT_PARAMS_owhttpd = "defaults 21"
+INITSCRIPT_NAME:owserver = "owserver"
+INITSCRIPT_NAME:owhttpd = "owhttpd"
+INITSCRIPT_PARAMS:owserver = "defaults 20"
+INITSCRIPT_PARAMS:owhttpd = "defaults 21"
-SYSTEMD_SERVICE_${PN} = "owfs.service"
-SYSTEMD_SERVICE_${PN}-owftpd = "owftpd.service"
-SYSTEMD_SERVICE_${PN}-owhttpd = "owhttpd.service"
-SYSTEMD_SERVICE_${PN}-owserver = "owserver.service owserver.socket"
+SYSTEMD_SERVICE:${PN} = "owfs.service"
+SYSTEMD_SERVICE:${PN}-owftpd = "owftpd.service"
+SYSTEMD_SERVICE:${PN}-owhttpd = "owhttpd.service"
+SYSTEMD_SERVICE:${PN}-owserver = "owserver.service owserver.socket"