aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb')
-rw-r--r--meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb10
1 files changed, 5 insertions, 5 deletions
diff --git a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
index 7f267b4972..571d4301ec 100644
--- a/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
+++ b/meta-gnome/recipes-gnome/evolution-data-server/evolution-data-server.bb
@@ -19,7 +19,7 @@ SRC_URI += " \
"
LKSTRFTIME = "HAVE_LKSTRFTIME=ON"
-LKSTRFTIME_libc-musl = "HAVE_LKSTRFTIME=OFF"
+LKSTRFTIME:libc-musl = "HAVE_LKSTRFTIME=OFF"
# For arm qemu-arm runs at 100% CPU load and never returns - so disable introspection for now
GI_DATA_ENABLED="False"
@@ -46,7 +46,7 @@ PACKAGECONFIG[openldap] = "-DWITH_OPENLDAP=ON,-DWITH_OPENLDAP=OFF,openldap"
# -ldb needs this on some platforms
LDFLAGS += "-lpthread -lgmodule-2.0 -lgthread-2.0"
-do_configure_append () {
+do_configure:append () {
cp ${WORKDIR}/iconv-detect.h ${S}/src
# fix native perl shebang
@@ -57,14 +57,14 @@ do_configure_append () {
-e 's: ${bindir}/g-ir-scanner-wrapper: ${STAGING_BINDIR}/g-ir-scanner-wrapper:g'
}
-do_compile_prepend() {
+do_compile:prepend() {
export GIR_EXTRA_LIBS_PATH="${B}/camel/.libs:${B}/libedataserver/.libs"
}
-FILES_${PN} =+ " \
+FILES:${PN} =+ " \
${datadir}/dbus-1 \
${datadir}/evolution-data-server-*/ui/ \
${systemd_user_unitdir} \
"
-RDEPENDS_${PN} += "perl"
+RDEPENDS:${PN} += "perl"