aboutsummaryrefslogtreecommitdiffstats
path: root/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb')
-rw-r--r--meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb19
1 files changed, 5 insertions, 14 deletions
diff --git a/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
index fb7e93eebd..8f3e4e1bb6 100644
--- a/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
+++ b/meta-gnome/recipes-gnome/orbit2/orbit2_2.14.17.bb
@@ -6,22 +6,20 @@ SRC_NAME = "ORBit2"
SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
SRC_URI = "${GNOME_MIRROR}/${SRC_NAME}/${SHRT_VER}/${SRC_NAME}-${PV}.tar.bz2 \
file://configure-lossage.patch \
- file://pkgconfig-fix.patch \
- file://gtk-doc.m4 \
- file://gtk-doc.make"
+ file://pkgconfig-fix.patch"
SRC_URI[md5sum] = "10bfb957fa4a8935a0b4afaee7d71df7"
SRC_URI[sha256sum] = "62bfce3f678f9347a19c766944e8aef7b89bc32b25ac23eb3e4c25929ce8974c"
-PR = "r2"
+PR = "r3"
BBCLASSEXTEND = "native"
IDL_COMPILER_DEPENDS = "orbit2-native"
IDL_COMPILER_DEPENDS_virtclass-native = " "
-DEPENDS = "libidl popt gtk-doc ${IDL_COMPILER_DEPENDS}"
+DEPENDS = "libidl popt ${IDL_COMPILER_DEPENDS}"
# IDL_COMPILER_DEPENDS_virtclass-native for some reason didn't work and orbit2-native
# was still in orbit2-native DEPENDS causing circular dependency
-DEPENDS_virtclass-native = "libidl-native popt-native gtk-doc-native"
+DEPENDS_virtclass-native = "libidl-native popt-native"
PARALLEL_MAKE = ""
@@ -33,14 +31,7 @@ S = "${WORKDIR}/${SRC_NAME}-${PV}"
LEAD_SONAME = "libORBit-2.so"
-inherit autotools pkgconfig
+inherit autotools pkgconfig gtk-doc
-EXTRA_OECONF = "--disable-gtk-doc"
EXTRA_OEMAKE = "IDL_COMPILER='${STAGING_BINDIR_NATIVE}/orbit-idl-2'"
EXTRA_OEMAKE_virtclass-native = " "
-
-do_configure_prepend() {
- mkdir -p m4
- install ${WORKDIR}/gtk-doc.m4 ./m4/
- install ${WORKDIR}/gtk-doc.make ./
-}