aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-connectivity/bluepy/bluepy_git.bb')
-rw-r--r--meta-networking/recipes-connectivity/bluepy/bluepy_git.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
new file mode 100644
index 0000000000..5b784d9a04
--- /dev/null
+++ b/meta-networking/recipes-connectivity/bluepy/bluepy_git.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Python interface to Bluetooth LE on Linux"
+HOMEPAGE = "https://github.com/IanHarvey/bluepy"
+SECTION = "devel/python"
+LICENSE = "GPL-2.0-only & PD"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=59e0d45ea684dda215889aa1b5acd001"
+DEPENDS = "glib-2.0"
+SRCREV = "7ad565231a97c304c0eff45f2649cd005e69db09"
+PV = "1.3.0+git"
+
+SRC_URI = "git://github.com/IanHarvey/bluepy.git;protocol=https;branch=master \
+ file://0001-bluepy-Fix-username-issue-with-tarballs.patch \
+ "
+
+S = "${WORKDIR}/git"
+
+inherit setuptools3 pkgconfig
+
+RDEPENDS:${PN} = "bluez5"
+
+TARGET_CC_ARCH += "${LDFLAGS}"