aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb')
-rw-r--r--meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
index bc33c18c0b..21e5c1877e 100644
--- a/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
+++ b/meta-networking/recipes-filter/ebtables/ebtables_2.0.11.bb
@@ -6,9 +6,9 @@ LICENSE = "GPLv2"
LIC_FILES_CHKSUM = "file://COPYING;md5=53b4a999993871a28ab1488fdbd2e73e"
SECTION = "net"
-RDEPENDS_${PN} += "bash perl"
+RDEPENDS:${PN} += "bash perl"
-RRECOMMENDS_${PN} += "kernel-module-ebtables \
+RRECOMMENDS:${PN} += "kernel-module-ebtables \
"
SRC_URI = "http://ftp.netfilter.org/pub/ebtables/ebtables-${PV}.tar.gz \
@@ -18,14 +18,14 @@ SRC_URI = "http://ftp.netfilter.org/pub/ebtables/ebtables-${PV}.tar.gz \
file://ebtables.service \
"
-SRC_URI_append_libc-musl = " file://0010-Adjust-header-include-sequence.patch"
+SRC_URI:append:libc-musl = " file://0010-Adjust-header-include-sequence.patch"
SRC_URI[md5sum] = "071c8b0a59241667a0044fb040d4fc72"
SRC_URI[sha256sum] = "b71f654784a726329f88b412ef7b96b4e5d786ed2bd28193ed7b4c0d677dfd2a"
inherit systemd autotools
-do_install_append () {
+do_install:append () {
# Replace upstream ebtables-save perl script with Fedora bash based rewrite
# http://pkgs.fedoraproject.org/cgit/rpms/ebtables.git/tree/ebtables-save
rm -f ${D}${sbindir}/ebtables-legacy-save
@@ -43,11 +43,11 @@ do_install_append () {
ln -sf ${sbindir}/ebtables-legacy ${D}${base_sbindir}/ebtables
}
-do_configure_prepend () {
+do_configure:prepend () {
( cd ${S}; ./autogen.sh )
}
-FILES_${PN}-dbg += "${base_libdir}/ebtables/.debug"
-FILES_${PN} += "${base_libdir}/ebtables/*.so"
+FILES:${PN}-dbg += "${base_libdir}/ebtables/.debug"
+FILES:${PN} += "${base_libdir}/ebtables/*.so"
-SYSTEMD_SERVICE_${PN} = "ebtables.service"
+SYSTEMD_SERVICE:${PN} = "ebtables.service"