aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/arptables
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/arptables')
-rw-r--r--meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
index 2faccec7d5..86b900a5da 100644
--- a/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
+++ b/meta-networking/recipes-support/arptables/arptables_0.0.3-4.bb
@@ -3,6 +3,8 @@ PRIORITY = "optional"
LICENSE = "GPL-2.0"
SECTION = "console/network"
+PR = "r2"
+
RDEPENDS_${PN} += "perl"
LIC_FILES_CHKSUM = "file://${COREBASE}/meta/files/common-licenses/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
@@ -20,6 +22,11 @@ do_compile () {
oe_runmake
}
+# the install target is not multi-job safe, but it doesn't do much
+# so we just install serially
+#
+PARALLEL_MAKEINST = "-j1"
+
fakeroot do_install () {
oe_runmake 'BINDIR=${sbindir}' 'MANDIR=${mandir}/' 'DESTDIR=${D}' install
}