aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-networking/recipes-support/esmtp/esmtp_1.2.bb')
-rw-r--r--meta-networking/recipes-support/esmtp/esmtp_1.2.bb18
1 files changed, 10 insertions, 8 deletions
diff --git a/meta-networking/recipes-support/esmtp/esmtp_1.2.bb b/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
index 972d5aa737..e60e1edd1f 100644
--- a/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
+++ b/meta-networking/recipes-support/esmtp/esmtp_1.2.bb
@@ -8,19 +8,21 @@ SECTION = "net"
DEPENDS = "libesmtp"
-LICENSE = "GPL-2.0"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=0636e73ff0215e8d672dc4c32c317bb3"
-SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BPN}-${PV}.tar.bz2"
+SRC_URI = "${SOURCEFORGE_MIRROR}/${BPN}/${PV}/${BPN}-${PV}.tar.bz2 \
+ file://0001-Fix-libESMTP-dependency-check.patch \
+ "
# Have to set this or we get -L/lib in LDFLAGS
EXTRA_OECONF = "--with-libesmtp=${STAGING_EXECPREFIXDIR}"
-inherit autotools update-alternatives
+inherit autotools update-alternatives pkgconfig
-ALTERNATIVE_${PN} = "sendmail mailq newaliases"
+ALTERNATIVE:${PN} = "sendmail mailq newaliases"
# /usr/lib/sendmial is required by LSB core test
-ALTERNATIVE_${PN}_linuxstdbase = "sendmail mailq newaliases usr-lib-sendmail"
+ALTERNATIVE:${PN}:linuxstdbase = "sendmail mailq newaliases usr-lib-sendmail"
ALTERNATIVE_TARGET[mailq] = "${bindir}/mailq"
ALTERNATIVE_TARGET[newaliases] = "${bindir}/newaliases"
ALTERNATIVE_LINK_NAME[sendmail] = "${sbindir}/sendmail"
@@ -30,7 +32,7 @@ ALTERNATIVE_TARGET[usr-lib-sendmail] = "${bindir}/esmtp"
ALTERNATIVE_PRIORITY = "10"
-ALTERNATIVE_${PN}-doc += "mailq.1 newaliases.1 sendmail.1"
+ALTERNATIVE:${PN}-doc += "mailq.1 newaliases.1 sendmail.1"
ALTERNATIVE_LINK_NAME[mailq.1] = "${mandir}/man1/mailq.1"
ALTERNATIVE_LINK_NAME[newaliases.1] = "${mandir}/man1/newaliases.1"
ALTERNATIVE_LINK_NAME[sendmail.1] = "${mandir}/man1/sendmail.1"
@@ -38,9 +40,9 @@ ALTERNATIVE_LINK_NAME[sendmail.1] = "${mandir}/man1/sendmail.1"
SRC_URI[md5sum] = "79a9c1f9023d53f35bb82bf446150a72"
SRC_URI[sha256sum] = "a0d26931bf731f97514da266d079d8bc7d73c65b3499ed080576ab606b21c0ce"
-do_install_append() {
+do_install:append() {
# only one file /usr/lib/sendmail in ${D}${libdir}
rm -rf ${D}${libdir}
}
-FILES_${PN} += "${libdir}/"
+FILES:${PN} += "${libdir}/"