aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/dynamic-layers/perl-layer/recipes-support
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/dynamic-layers/perl-layer/recipes-support')
-rw-r--r--meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb8
-rw-r--r--meta-oe/dynamic-layers/perl-layer/recipes-support/rasdaemon/rasdaemon_0.6.7.bb18
2 files changed, 13 insertions, 13 deletions
diff --git a/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb b/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
index 07ab5e62b1..8c53af4cf6 100644
--- a/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
+++ b/meta-oe/dynamic-layers/perl-layer/recipes-support/debsums/debsums_2.2.2.bb
@@ -1,10 +1,10 @@
SUMMARY = "Miscellaneous utilities specific to Debian"
-SUMMARY_${PN}-cron = "Cron scripts to control automatic debsum checking"
+SUMMARY:${PN}-cron = "Cron scripts to control automatic debsum checking"
DESCRIPTION = "A tool for verification of installed package files against \
MD5 checksums debsums can verify the integrity of installed package files \
against MD5 checksums installed by the package, or generated from a .deb \
archive."
-DESCRIPTION_${PN}-cron = "Cron scripts to control automatic system integrity \
+DESCRIPTION:${PN}-cron = "Cron scripts to control automatic system integrity \
checking via debsums."
SECTION = "base"
LICENSE = "GPLv2"
@@ -44,7 +44,7 @@ do_install() {
PACKAGES =+ "${PN}-cron"
-RDEPENDS_${PN} = "dpkg dpkg-perl libfile-fnmatch-perl perl \
+RDEPENDS:${PN} = "dpkg dpkg-perl libfile-fnmatch-perl perl \
perl-module-constant perl-module-digest-md5 \
perl-module-errno perl-module-fcntl \
perl-module-file-basename perl-module-file-copy \
@@ -53,4 +53,4 @@ RDEPENDS_${PN} = "dpkg dpkg-perl libfile-fnmatch-perl perl \
perl-module-file-temp perl-module-getopt-long \
perl-module-posix"
-FILES_${PN}-cron = "${sysconfdir}/cron.*"
+FILES:${PN}-cron = "${sysconfdir}/cron.*"
diff --git a/meta-oe/dynamic-layers/perl-layer/recipes-support/rasdaemon/rasdaemon_0.6.7.bb b/meta-oe/dynamic-layers/perl-layer/recipes-support/rasdaemon/rasdaemon_0.6.7.bb
index 39ed3d1071..a68dfa1d01 100644
--- a/meta-oe/dynamic-layers/perl-layer/recipes-support/rasdaemon/rasdaemon_0.6.7.bb
+++ b/meta-oe/dynamic-layers/perl-layer/recipes-support/rasdaemon/rasdaemon_0.6.7.bb
@@ -12,7 +12,7 @@ SRCREV = "aa96737648d867a3d73e4151d05b54bbab494605"
S = "${WORKDIR}/git"
-RDEPENDS_${BPN} = "perl perl-module-file-basename perl-module-file-find perl-module-file-spec perl-module-getopt-long \
+RDEPENDS:${BPN} = "perl perl-module-file-basename perl-module-file-find perl-module-file-spec perl-module-getopt-long \
perl-module-posix perl-module-file-glob libdbi-perl libdbd-sqlite-perl"
inherit autotools pkgconfig update-rc.d systemd
@@ -29,27 +29,27 @@ PACKAGECONFIG[hisi-ns-decode] = "--enable-hisi-ns-decode,--disable-hisi-ns-decod
PACKAGECONFIG[non-standard] = "--enable-non-standard,--disable-non-standard"
PACKAGECONFIG[abrt-report] = "--enable-abrt-report,--disable-abrt-report"
-DEPENDS_append_libc-musl = " argp-standalone"
-LDFLAGS_append_libc-musl = " -largp"
+DEPENDS:append:libc-musl = " argp-standalone"
+LDFLAGS:append:libc-musl = " -largp"
-do_configure_prepend () {
+do_configure:prepend () {
( cd ${S}; autoreconf -vfi )
}
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/init.d
install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/rasdaemon
install -d ${D}${systemd_unitdir}/system
install -m 0644 ${WORKDIR}/rasdaemon.service ${D}${systemd_unitdir}/system
}
-FILES_${PN} += "${sbindir}/rasdaemon \
+FILES:${PN} += "${sbindir}/rasdaemon \
${sysconfdir}/init.d \
${systemd_unitdir}/system/rasdaemon.service"
-SYSTEMD_SERVICE_${PN} = "rasdaemon.service"
+SYSTEMD_SERVICE:${PN} = "rasdaemon.service"
SYSTEMD_AUTO_ENABLE = "enable"
INITSCRIPT_PACKAGES = "${PN}"
-INITSCRIPT_NAME_${PN} = "rasdaemon"
-INITSCRIPT_PARAMS_${PN} = "defaults 89"
+INITSCRIPT_NAME:${PN} = "rasdaemon"
+INITSCRIPT_PARAMS:${PN} = "defaults 89"