aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb')
-rw-r--r--meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb29
1 files changed, 15 insertions, 14 deletions
diff --git a/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
index e0d3bef3ca..c7a0562db4 100644
--- a/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
+++ b/meta-oe/recipes-connectivity/libtorrent/libtorrent_git.bb
@@ -1,32 +1,33 @@
DESCRIPTION = "libTorrent is a BitTorrent library written in C++ for *nix, \
with a focus on high performance and good code."
HOMEPAGE = "http://libtorrent.rakshasa.no/"
-LICENSE = "GPL-2.0"
+LICENSE = "GPL-2.0-or-later"
LIC_FILES_CHKSUM = "file://COPYING;md5=393a5ca445f6965873eca0259a17f833"
DEPENDS = "zlib libsigc++-2.0 openssl cppunit"
-SRC_URI = "git://github.com/rakshasa/libtorrent \
- file://don-t-run-code-while-configuring-package.patch \
- "
-SRCREV = "756f70010779927dc0691e1e722ed433d5d295e1"
+PV = "0.13.8+git"
-PV = "0.13.8"
+SRC_URI = "git://github.com/rakshasa/libtorrent;branch=master;protocol=https"
+SRCREV = "e60f222241319aaae482789517ad00ae9344bd13"
+
+UPSTREAM_CHECK_GITTAGREGEX = "v(?P<pver>\d+(\.\d+)+)"
+
+CVE_STATUS[CVE-2009-1760] = "backported-patch: patched in our product"
S = "${WORKDIR}/git"
-PACKAGECONFIG ??= "instrumentation"
+CVE_PRODUCT = ""
-PACKAGECONFIG_remove_mipsarch = "instrumentation"
-PACKAGECONFIG_remove_powerpc = "instrumentation"
-PACKAGECONFIG_remove_riscv32 = "instrumentation"
+PACKAGECONFIG ??= "instrumentation aligned"
+
+PACKAGECONFIG:remove:mipsarch = "instrumentation"
+PACKAGECONFIG:remove:powerpc = "instrumentation"
+PACKAGECONFIG:remove:riscv32 = "instrumentation"
PACKAGECONFIG[instrumentation] = "--enable-instrumentation,--disable-instrumentation,"
+PACKAGECONFIG[aligned] = "--enable-aligned,--disable-aligned,"
inherit autotools pkgconfig
EXTRA_OECONF = "--with-zlib=${STAGING_EXECPREFIXDIR}"
-
-do_configure_prepend() {
- (cd ${S}; ./autogen.sh; cd -)
-}