aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-crypto/botan/botan_2.18.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-crypto/botan/botan_2.18.1.bb')
-rw-r--r--meta-oe/recipes-crypto/botan/botan_2.18.1.bb12
1 files changed, 6 insertions, 6 deletions
diff --git a/meta-oe/recipes-crypto/botan/botan_2.18.1.bb b/meta-oe/recipes-crypto/botan/botan_2.18.1.bb
index 041eff039d..62872ff852 100644
--- a/meta-oe/recipes-crypto/botan/botan_2.18.1.bb
+++ b/meta-oe/recipes-crypto/botan/botan_2.18.1.bb
@@ -12,9 +12,9 @@ S = "${WORKDIR}/Botan-${PV}"
inherit python3native siteinfo lib_package
CPU ?= "${TARGET_ARCH}"
-CPU_x86 = "x86_32"
-CPU_armv7a = "armv7"
-CPU_armv7ve = "armv7"
+CPU:x86 = "x86_32"
+CPU:armv7a = "armv7"
+CPU:armv7ve = "armv7"
do_configure() {
python3 ${S}/configure.py \
@@ -45,8 +45,8 @@ do_install() {
PACKAGES += "${PN}-python3"
-FILES_${PN}-python3 = "${libdir}/python3"
+FILES:${PN}-python3 = "${libdir}/python3"
-RDEPENDS_${PN}-python3 += "python3"
+RDEPENDS:${PN}-python3 += "python3"
-COMPATIBLE_HOST_riscv32 = "null"
+COMPATIBLE_HOST:riscv32 = "null"