aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb')
-rw-r--r--meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb b/meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb
index 06f7947642..fa360b8d1d 100644
--- a/meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb
+++ b/meta-oe/recipes-dbs/influxdb/influxdb_1.7.10.bb
@@ -4,10 +4,10 @@ HOMEPAGE = "https://www.influxdata.com/products/influxdb-overview/"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://src/${GO_IMPORT}/LICENSE;md5=ba8146ad9cc2a128209983265136e06a"
-FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
+FILESEXTRAPATHS:prepend := "${THISDIR}/${PN}:"
-RDEPENDS_${PN} = "bash"
-RDEPENDS_${PN}-dev = "bash"
+RDEPENDS:${PN} = "bash"
+RDEPENDS:${PN}-dev = "bash"
GO_IMPORT = "github.com/influxdata/influxdb"
@@ -22,22 +22,22 @@ SRC_URI = "\
file://influxdb.conf \
"
-SRC_URI_append_mipsarch = " file://0001-patch-term-module-for-mips-ispeed-ospeed-termios-abs.patch;patchdir=src/${GO_IMPORT}"
+SRC_URI:append:mipsarch = " file://0001-patch-term-module-for-mips-ispeed-ospeed-termios-abs.patch;patchdir=src/${GO_IMPORT}"
SRCREV = "c958f436b2e538a88a7815aad721c7774a0b8f63"
inherit go-mod systemd update-rc.d useradd
USERADD_PACKAGES = "${PN}"
-USERADD_PARAM_${PN} = "--system -d /var/lib/influxdb -m -s /bin/nologin influxdb"
+USERADD_PARAM:${PN} = "--system -d /var/lib/influxdb -m -s /bin/nologin influxdb"
-do_install_prepend() {
+do_install:prepend() {
rm ${B}/src/${GO_IMPORT}/build.py
rm ${B}/src/${GO_IMPORT}/build.sh
rm ${B}/src/${GO_IMPORT}/Dockerfile*
}
-do_install_append() {
+do_install:append() {
install -d ${D}${sysconfdir}/influxdb
install -m 0644 ${WORKDIR}/influxdb.conf ${D}${sysconfdir}/influxdb
chown -R root.influxdb ${D}${sysconfdir}/influxdb
@@ -62,4 +62,4 @@ INITSCRIPT_PACKAGES = "${PN}"
INITSCRIPT_NAME = "influxdb"
INITSCRIPT_PARAMS = "defaults"
-SYSTEMD_SERVICE_${PN} = "influxdb.service"
+SYSTEMD_SERVICE:${PN} = "influxdb.service"