aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-dbs/mysql
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-dbs/mysql')
-rw-r--r--meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb b/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
index 6d52222ce4..f1c2b7701c 100644
--- a/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
+++ b/meta-oe/recipes-dbs/mysql/mysql-python_1.2.5.bb
@@ -16,4 +16,9 @@ SRC_URI[sha256sum] = "811040b647e5d5686f84db415efd697e6250008b112b6909ba77ac059e
S = "${WORKDIR}/${SRCNAME}-${PV}"
-inherit setuptools3
+inherit setuptools
+
+python() {
+ if 'meta-python2' not in d.getVar('BBFILE_COLLECTIONS').split():
+ raise bb.parse.SkipRecipe('Requires meta-python2 to be present.')
+}