aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/abseil-cpp
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/abseil-cpp')
-rw-r--r--meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb24
1 files changed, 0 insertions, 24 deletions
diff --git a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
index cc7bf01d73..7d935d523b 100644
--- a/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
+++ b/meta-oe/recipes-devtools/abseil-cpp/abseil-cpp_git.bb
@@ -34,27 +34,3 @@ ALLOW_EMPTY_${PN} = "1"
FILES_${PN} = "${libdir}/libabsl_*.so ${libdir}/cmake"
FILES_${PN}-dev = "${includedir}"
-python () {
- arch = d.getVar("TARGET_ARCH")
-
- if arch == "aarch64":
- tunes = d.getVar("TUNE_FEATURES")
- if not tunes:
- raise bb.parse.SkipRecipe("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
- return
- pkgn = d.getVar("PN")
- pkgv = d.getVar("PV")
- if "crypto" not in tunes:
- raise bb.parse.SkipRecipe("%s-%s Needs support for crypto on armv8" % (pkgn, pkgv))
-
- if arch == "x86_64":
- tunes = d.getVar("TUNE_FEATURES")
- if not tunes:
- raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
- return
- pkgn = d.getVar("PN")
- pkgv = d.getVar("PV")
- if "corei7" not in tunes:
- raise bb.parse.SkipRecipe("%s-%s Needs support for corei7 on x86_64" % (pkgn, pkgv))
-
-}