aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb')
-rw-r--r--meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb b/meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb
new file mode 100644
index 0000000000..200f751669
--- /dev/null
+++ b/meta-oe/recipes-devtools/cjson/cjson_1.7.15.bb
@@ -0,0 +1,21 @@
+DESCRIPTION = "Ultralightweight JSON parser in ANSI C"
+AUTHOR = "Dave Gamble"
+HOMEPAGE = "https://github.com/DaveGamble/cJSON"
+SECTION = "libs"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=218947f77e8cb8e2fa02918dc41c50d0"
+
+SRC_URI = "git://github.com/DaveGamble/cJSON.git;branch=master;protocol=https"
+SRCREV = "d348621ca93571343a56862df7de4ff3bc9b5667"
+
+S = "${WORKDIR}/git"
+
+inherit cmake pkgconfig
+
+EXTRA_OECMAKE += "\
+ -DENABLE_CJSON_UTILS=On \
+ -DENABLE_CUSTOM_COMPILER_FLAGS=OFF \
+ -DBUILD_SHARED_AND_STATIC_LIBS=On \
+"
+
+BBCLASSEXTEND = "native nativesdk"