aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/lua/lua/uclibc-pthread.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/lua/lua/uclibc-pthread.patch')
-rw-r--r--meta-oe/recipes-devtools/lua/lua/uclibc-pthread.patch13
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/lua/lua/uclibc-pthread.patch b/meta-oe/recipes-devtools/lua/lua/uclibc-pthread.patch
new file mode 100644
index 0000000000..f4cdc5d8c5
--- /dev/null
+++ b/meta-oe/recipes-devtools/lua/lua/uclibc-pthread.patch
@@ -0,0 +1,13 @@
+Index: lua-5.1.4/src/Makefile
+===================================================================
+--- a/src/Makefile.orig 2013-10-22 22:17:19.929103523 -0400
++++ a/src/Makefile 2013-10-22 22:18:27.992104545 -0400
+@@ -9,7 +9,7 @@
+ CC= gcc
+ CFLAGS= -O2 -Wall -DLUA_COMPAT_ALL $(SYSCFLAGS) $(MYCFLAGS)
+ LDFLAGS= $(SYSLDFLAGS) $(MYLDFLAGS)
+-LIBS= -lm $(SYSLIBS) $(MYLIBS)
++LIBS= -lm -lpthread $(SYSLIBS) $(MYLIBS)
+
+ AR= ar rcu
+ RANLIB= ranlib