aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools/python/python3-pyparsing_2.4.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools/python/python3-pyparsing_2.4.6.bb')
-rw-r--r--meta-oe/recipes-devtools/python/python3-pyparsing_2.4.6.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/python/python3-pyparsing_2.4.6.bb b/meta-oe/recipes-devtools/python/python3-pyparsing_2.4.6.bb
new file mode 100644
index 0000000000..a6ec1cb9c3
--- /dev/null
+++ b/meta-oe/recipes-devtools/python/python3-pyparsing_2.4.6.bb
@@ -0,0 +1,21 @@
+SUMMARY = "Python parsing module"
+HOMEPAGE = "http://pyparsing.wikispaces.com/"
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=657a566233888513e1f07ba13e2f47f1"
+
+SRC_URI[md5sum] = "29733ea8cbee0291aad121c69c6e51a1"
+SRC_URI[sha256sum] = "4c830582a84fb022400b85429791bc551f1f4871c33f23e44f353119e92f969f"
+
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+ ${PYTHON_PN}-debugger \
+ ${PYTHON_PN}-json \
+ ${PYTHON_PN}-netclient \
+ ${PYTHON_PN}-pprint \
+ ${PYTHON_PN}-stringold \
+ ${PYTHON_PN}-threading \
+"
+
+BBCLASSEXTEND = "native nativesdk"