aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb2
-rw-r--r--meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb2
-rw-r--r--meta-oe/recipes-devtools/orc/orc.inc2
-rw-r--r--meta-oe/recipes-devtools/vala/vala.inc2
4 files changed, 4 insertions, 4 deletions
diff --git a/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb b/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb
index c2f1cc82e6..8b796ac675 100644
--- a/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb
+++ b/meta-oe/recipes-devtools/libcanberra/libcanberra_0.26.bb
@@ -29,7 +29,7 @@ EXTRA_OECONF = "\
# enable pulse again when pulseaudio >= 0.9.11 is the default in OE
python populate_packages_prepend() {
- plugindir = bb.data.expand('${libdir}/${P}/', d)
+ plugindir = d.expand('${libdir}/${P}/')
do_split_packages(d, plugindir, '^libcanberra-(.*)\.so$', 'libcanberra-%s', '%s support library', extra_depends='' )
}
diff --git a/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb b/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb
index a6044cdf37..fbd14662fd 100644
--- a/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb
+++ b/meta-oe/recipes-devtools/libgee/libgee_0.6.4.bb
@@ -4,7 +4,7 @@ PR = "${INC_PR}.2"
DEPENDS += "gobject-introspection-stub"
DEPENDS_virtclass-native += "gobject-introspection-stub-native"
-SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/libgee/${SHRT_VER}/${BP}.tar.xz"
SRC_URI[md5sum] = "a32bf498cf33d5e3417823a7b252ad22"
SRC_URI[sha256sum] = "55f39f3b28e676f6cbd9377d83edd031084436a4da41280a9503c94faffb1665"
diff --git a/meta-oe/recipes-devtools/orc/orc.inc b/meta-oe/recipes-devtools/orc/orc.inc
index 6efe025648..7a957f3249 100644
--- a/meta-oe/recipes-devtools/orc/orc.inc
+++ b/meta-oe/recipes-devtools/orc/orc.inc
@@ -16,7 +16,7 @@ FILES_orc-examples = "${libdir}/orc/*"
FILES_${PN} = "${bindir}/*"
python populate_packages_prepend () {
- libdir = bb.data.expand('${libdir}', d)
+ libdir = d.expand('${libdir}')
do_split_packages(d, libdir, '^lib(.*)\.so\.*', 'lib%s', 'ORC %s library', extra_depends='', allow_links=True)
}
diff --git a/meta-oe/recipes-devtools/vala/vala.inc b/meta-oe/recipes-devtools/vala/vala.inc
index 3d33953b6b..6cdc6053b8 100644
--- a/meta-oe/recipes-devtools/vala/vala.inc
+++ b/meta-oe/recipes-devtools/vala/vala.inc
@@ -9,7 +9,7 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING;md5=fbc093901857fcd118f065f900982c24"
INC_PR = "r1"
-SHRT_VER = "${@bb.data.getVar('PV',d,1).split('.')[0]}.${@bb.data.getVar('PV',d,1).split('.')[1]}"
+SHRT_VER = "${@d.getVar('PV',1).split('.')[0]}.${@d.getVar('PV',1).split('.')[1]}"
SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/${BPN}/${SHRT_VER}/${BP}.tar.xz"
inherit autotools