aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-devtools
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-devtools')
-rw-r--r--meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb b/meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb
index 5097b2b1b8..363e2b4680 100644
--- a/meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb
+++ b/meta-oe/recipes-devtools/grpc/grpc_1.35.0.bb
@@ -35,6 +35,11 @@ EXTRA_OECMAKE = " \
-DgRPC_INSTALL_CMAKEDIR=${baselib}/cmake/${BPN} \
"
+do_configure_prepend() {
+ sed -i -e "s#lib/pkgconfig/#${baselib}/pkgconfig/#g" ${S}/CMakeLists.txt
+}
+
+
do_configure_prepend_mipsarch() {
sed -i -e "s/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} rt m pthread)/set(_gRPC_ALLTARGETS_LIBRARIES \${CMAKE_DL_LIBS} atomic rt m pthread)/g" ${S}/CMakeLists.txt
}