aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/ostree/ostree_2021.3.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/ostree/ostree_2021.3.bb')
-rw-r--r--meta-oe/recipes-extended/ostree/ostree_2021.3.bb40
1 files changed, 20 insertions, 20 deletions
diff --git a/meta-oe/recipes-extended/ostree/ostree_2021.3.bb b/meta-oe/recipes-extended/ostree/ostree_2021.3.bb
index c735f6d8b8..a0576b51e2 100644
--- a/meta-oe/recipes-extended/ostree/ostree_2021.3.bb
+++ b/meta-oe/recipes-extended/ostree/ostree_2021.3.bb
@@ -45,7 +45,7 @@ PACKAGECONFIG ??= " \
# We include soup because ostree can't (currently) be built without
# soup or curl - https://github.com/ostreedev/ostree/issues/1897
-PACKAGECONFIG_class-native ??= " \
+PACKAGECONFIG:class-native ??= " \
${@bb.utils.filter('DISTRO_FEATURES', 'selinux smack', d)} \
builtin-grub2-mkconfig \
gpgme \
@@ -84,7 +84,7 @@ EXTRA_OEMAKE = " \
INTROSPECTION_SCANNER_ENV= \
"
-EXTRA_OECONF_class-native = " \
+EXTRA_OECONF:class-native = " \
--enable-wrpseudo-compat \
--disable-otmpfile \
"
@@ -92,17 +92,17 @@ EXTRA_OECONF_class-native = " \
# Path to ${prefix}/lib/ostree/ostree-grub-generator is hardcoded on the
# do_configure stage so we do depend on it
SYSROOT_DIR = "${STAGING_DIR_TARGET}"
-SYSROOT_DIR_class-native = "${STAGING_DIR_NATIVE}"
+SYSROOT_DIR:class-native = "${STAGING_DIR_NATIVE}"
do_configure[vardeps] += "SYSROOT_DIR"
-do_configure_prepend() {
+do_configure:prepend() {
# this reflects what autogen.sh does, but the OE wrappers for autoreconf
# allow it to work without the other gyrations which exist there
cp ${S}/libglnx/Makefile-libglnx.am ${S}/libglnx/Makefile-libglnx.am.inc
cp ${S}/bsdiff/Makefile-bsdiff.am ${S}/bsdiff/Makefile-bsdiff.am.inc
}
-do_install_append_class-native() {
+do_install:append:class-native() {
create_wrapper ${D}${bindir}/ostree OSTREE_GRUB2_EXEC="${STAGING_LIBDIR_NATIVE}/ostree/ostree-grub-generator"
}
@@ -114,38 +114,38 @@ PACKAGE_BEFORE_PN = " \
${PN}-trivial-httpd \
"
-FILES_${PN} += " \
+FILES:${PN} += " \
${nonarch_libdir}/${BPN} \
${nonarch_libdir}/tmpfiles.d \
${systemd_unitdir}/system \
${systemd_unitdir}/system-generators \
"
-FILES_${PN}-dracut = " \
+FILES:${PN}-dracut = " \
${sysconfdir}/dracut.conf.d \
${libdir}/dracut \
"
-FILES_${PN}-grub = " \
+FILES:${PN}-grub = " \
${sysconfdir}/grub.d \
${libexecdir}/libostree/grub2-15_ostree \
"
-FILES_${PN}-mkinitcpio = " \
+FILES:${PN}-mkinitcpio = " \
${sysconfdir}/ostree-mkinitcpio.conf \
${libdir}/initcpio \
"
-FILES_${PN}-switchroot = " \
+FILES:${PN}-switchroot = " \
${nonarch_libdir}/${BPN}/ostree-prepare-root \
${systemd_unitdir}/system/ostree-prepare-root.service \
"
-FILES_${PN}-trivial-httpd = " \
+FILES:${PN}-trivial-httpd = " \
${libexecdir}/libostree/ostree-trivial-httpd \
"
-RDEPENDS_${PN} = " \
+RDEPENDS:${PN} = " \
${@bb.utils.contains('PACKAGECONFIG', 'trivial-httpd-cmdline', '${PN}-trivial-httpd', '', d)} \
"
-RDEPENDS_${PN}-dracut = "bash"
-RDEPENDS_${PN}-mkinitcpio = "bash"
-RDEPENDS_${PN}_class-target = " \
+RDEPENDS:${PN}-dracut = "bash"
+RDEPENDS:${PN}-mkinitcpio = "bash"
+RDEPENDS:${PN}:class-target = " \
${@bb.utils.contains('PACKAGECONFIG', 'gpgme', 'gnupg', '', d)} \
${PN}-switchroot \
"
@@ -161,7 +161,7 @@ RDEPENDS_${PN}_class-target = " \
# /var/tmp as a real filesystem (not a tmpfs)
# Sufficient disk space (IMAGE_ROOTFS_SIZE = "524288") and RAM (QB_MEM = "-m 1024")
#
-RDEPENDS_${PN}-ptest += " \
+RDEPENDS:${PN}-ptest += " \
attr \
bash \
coreutils \
@@ -179,11 +179,11 @@ RDEPENDS_${PN}-ptest += " \
python3-pyyaml \
${@bb.utils.contains('PACKAGECONFIG', 'gjs', 'gjs', '', d)} \
"
-RDEPENDS_${PN}-ptest_append_libc-glibc = " glibc-utils glibc-localedata-en-us"
+RDEPENDS:${PN}-ptest:append:libc-glibc = " glibc-utils glibc-localedata-en-us"
-RRECOMMENDS_${PN} += "kernel-module-overlay"
+RRECOMMENDS:${PN} += "kernel-module-overlay"
-SYSTEMD_SERVICE_${PN} = "ostree-remount.service ostree-finalize-staged.path"
-SYSTEMD_SERVICE_${PN}-switchroot = "ostree-prepare-root.service"
+SYSTEMD_SERVICE:${PN} = "ostree-remount.service ostree-finalize-staged.path"
+SYSTEMD_SERVICE:${PN}-switchroot = "ostree-prepare-root.service"
BBCLASSEXTEND = "native"