aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/acpica/acpica_20130626.bb37
-rw-r--r--meta-oe/recipes-extended/acpica/files/cross-compile.patch19
-rw-r--r--meta-oe/recipes-extended/acpica/files/no-werror.patch36
3 files changed, 92 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/acpica/acpica_20130626.bb b/meta-oe/recipes-extended/acpica/acpica_20130626.bb
new file mode 100644
index 0000000000..65eadac0d8
--- /dev/null
+++ b/meta-oe/recipes-extended/acpica/acpica_20130626.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "The ACPI Component Architecture (ACPICA) project provides an \
+OS-independent reference implementation of the Advanced Configuration and \
+Power Interface Specification (ACPI). ACPICA code contains those portions of \
+ACPI meant to be directly integrated into the host OS as a kernel-resident \
+subsystem, and a small set of tools to assist in developing and debugging \
+ACPI tables."
+SUMMARY = "ACPICA tools for the development and debug of ACPI tables"
+HOMEPAGE = "http://www.acpica.org/"
+SECTION = "console/tools"
+LICENSE = "BSD | GPLv2"
+LIC_FILES_CHKSUM = "file://generate/unix/readme.txt;md5=204407e197c1a01154a48f6c6280c3aa"
+DEPENDS="bison \
+ flex"
+COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux"
+
+PR="r1"
+
+SRC_URI="https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \
+ file://cross-compile.patch \
+ file://no-werror.patch"
+
+SRC_URI[md5sum] = "b7112b3deffef8fe25aac7810cc419a9"
+SRC_URI[sha256sum] = "888dda6227265c396a686624f971c51693c2bba84f24c634536234c8dca7b465"
+
+S="${WORKDIR}/acpica-unix2-${PV}"
+
+EXTRA_OEMAKE = "'OPT_CFLAGS=-Wall'"
+
+do_install() {
+ install -D -p -m0755 generate/unix/bin*/iasl ${D}${bindir}/iasl
+ install -D -p -m0755 generate/unix/bin*/acpibin ${D}${bindir}/acpibin
+ install -D -p -m0755 generate/unix/bin*/acpiexec ${D}${bindir}/acpiexec
+ install -D -p -m0755 generate/unix/bin*/acpihelp ${D}${bindir}/acpihelp
+ install -D -p -m0755 generate/unix/bin*/acpinames ${D}${bindir}/acpinames
+ install -D -p -m0755 generate/unix/bin*/acpisrc ${D}${bindir}/acpisrc
+ install -D -p -m0755 generate/unix/bin*/acpixtract ${D}${bindir}/acpixtract
+}
diff --git a/meta-oe/recipes-extended/acpica/files/cross-compile.patch b/meta-oe/recipes-extended/acpica/files/cross-compile.patch
new file mode 100644
index 0000000000..f2917ca994
--- /dev/null
+++ b/meta-oe/recipes-extended/acpica/files/cross-compile.patch
@@ -0,0 +1,19 @@
+Description: add cross compile support
+Forwarded: not-needed
+Author: Fathi Boudra <fathi.boudra@linaro.org>
+
+---
+ generate/unix/Makefile.config | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+--- a/generate/unix/Makefile.config
++++ b/generate/unix/Makefile.config
+@@ -35,7 +35,7 @@
+ .SUFFIXES :
+ PROGS = acpibin acpidump acpiexec acpihelp acpinames acpisrc acpixtract iasl
+ HOST ?= _CYGWIN
+-CC = gcc
++CC ?= $(CROSS_COMPILE)gcc
+
+ #
+ # Common defines
diff --git a/meta-oe/recipes-extended/acpica/files/no-werror.patch b/meta-oe/recipes-extended/acpica/files/no-werror.patch
new file mode 100644
index 0000000000..9f96552fd0
--- /dev/null
+++ b/meta-oe/recipes-extended/acpica/files/no-werror.patch
@@ -0,0 +1,36 @@
+Description: remove -Werror flag
+Forwarded: not-needed
+Author: Fathi Boudra <fathi.boudra@linaro.org>
+
+---
+ generate/unix/iasl/Makefile | 12 ++++++------
+ 1 file changed, 6 insertions(+), 6 deletions(-)
+
+--- a/generate/unix/iasl/Makefile
++++ b/generate/unix/iasl/Makefile
+@@ -279,19 +279,19 @@ $(OBJDIR)/prparser.y.h: $(OBJDIR)/prpars
+ # by the utilities above and they are not necessarily ANSI C, etc.
+ #
+ $(OBJDIR)/aslcompilerlex.o : $(OBJDIR)/aslcompilerlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/aslcompilerparse.o : $(OBJDIR)/aslcompilerparse.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/dtparserlex.o : $(OBJDIR)/dtparserlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/dtparserparse.o : $(OBJDIR)/dtparserparse.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/prparserlex.o : $(OBJDIR)/prparserlex.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?
+
+ $(OBJDIR)/prparserparse.o : $(OBJDIR)/prparserparse.c
+- $(CC) -c $(CFLAGS) -Wall -Werror -o$@ $?
++ $(CC) -c $(CFLAGS) -Wall -o$@ $?