aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/surf/surf_2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/surf/surf_2.1.bb')
-rw-r--r--meta-oe/recipes-graphics/surf/surf_2.1.bb13
1 files changed, 9 insertions, 4 deletions
diff --git a/meta-oe/recipes-graphics/surf/surf_2.1.bb b/meta-oe/recipes-graphics/surf/surf_2.1.bb
index 710ed9bce9..4d9d4d3dd0 100644
--- a/meta-oe/recipes-graphics/surf/surf_2.1.bb
+++ b/meta-oe/recipes-graphics/surf/surf_2.1.bb
@@ -5,20 +5,25 @@ SECTION = "x11/graphics"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://LICENSE;md5=2a6f86d002ae9ae1eb1ccc466289f146"
-DEPENDS = "webkitgtk gtk+3 glib-2.0 gcr"
+DEPENDS = "webkitgtk3 gtk+3 glib-2.0 gcr3"
REQUIRED_DISTRO_FEATURES = "x11 opengl"
+SRCREV = "665a709b522a6fa18c671f1fc41297603292d0e8"
SRC_URI = "git://git.suckless.org/surf;branch=surf-webkit2 \
- file://0001-config.mk-Fix-compiler-and-linker.patch \
- file://0001-config.ml-make-compatible-with-webkitgtk-2.34.0.patch \
"
-SRCREV = "bcd7d74e613fb8af11b40c351f0a6c1a771b2d2b"
+SRC_URI += "${@bb.utils.contains('PACKAGECONFIG', 'soup3', 'file://0001-config.mk-Fix-compiler-and-linker.patch file://0001-config.ml-make-compatible-with-webkitgtk-2.34.0.patch', '', d)}"
S = "${WORKDIR}/git"
inherit pkgconfig features_check
+PACKAGECONFIG_SOUP ?= "soup3"
+PACKAGECONFIG ??= "${PACKAGECONFIG_SOUP}"
+
+PACKAGECONFIG[soup2] = ",,,"
+PACKAGECONFIG[soup3] = ",,,"
+
TARGET_CC_ARCH += "${LDFLAGS}"
do_install () {