aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r--meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
index 481e438994..5bc37b03f4 100644
--- a/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
+++ b/meta-oe/recipes-graphics/xserver-common/xserver-common_1.34.bb
@@ -28,6 +28,13 @@ SRC_URI_append = " \
do_install_append() {
sed -i 's:^BINDIR=.*$:BINDIR=${bindir}:' ${D}/etc/X11/xserver-common
+ # Rename all Xsession files not ending with .sh
+ # Unfortunatelly when xinput-calibrator was moved to oe-core
+ # its Xsession file got name 30xinput_calibrate.sh and ls -X sorts it
+ # last, not respecting numbers for sorting them
+ for i in ${D}/${sysconfdir}/X11/Xsession.d/*; do
+ echo $i | grep '.sh$' || mv $i $i.sh
+ done
}
inherit allarch