aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/bpftool/bpftool.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/bpftool/bpftool.bb')
-rw-r--r--meta-oe/recipes-kernel/bpftool/bpftool.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta-oe/recipes-kernel/bpftool/bpftool.bb b/meta-oe/recipes-kernel/bpftool/bpftool.bb
index f0696db59b..76a749644b 100644
--- a/meta-oe/recipes-kernel/bpftool/bpftool.bb
+++ b/meta-oe/recipes-kernel/bpftool/bpftool.bb
@@ -25,7 +25,7 @@ SECURITY_CFLAGS = ""
do_configure[depends] += "virtual/kernel:do_shared_workdir"
COMPATIBLE_HOST = "(x86_64).*-linux"
-COMPATIBLE_HOST_libc-musl = 'null'
+COMPATIBLE_HOST:libc-musl = 'null'
do_compile() {
oe_runmake
@@ -37,7 +37,7 @@ do_install() {
PACKAGE_ARCH = "${MACHINE_ARCH}"
-python do_package_prepend() {
+python do_package:prepend() {
d.setVar('PKGV', d.getVar("KERNEL_VERSION").split("-")[0])
}