aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/ktap/ktap_0.4.bb')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.4.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.4.bb b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
new file mode 100644
index 0000000000..f5dd62f849
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.4.bb
@@ -0,0 +1,17 @@
+# Released under the MIT license (see COPYING.MIT for the terms)
+
+require ktap.inc
+
+SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
+DEPENDS = "ktap-module"
+
+# Only build the userspace app
+EXTRA_OEMAKE = "ktap"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${S}/ktap ${D}${bindir}/
+}
+
+RDEPENDS_${PN} = "kernel-module-ktapvm"
+