aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-multimedia/vlc/vlc.inc
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-multimedia/vlc/vlc.inc')
-rw-r--r--meta-oe/recipes-multimedia/vlc/vlc.inc100
1 files changed, 50 insertions, 50 deletions
diff --git a/meta-oe/recipes-multimedia/vlc/vlc.inc b/meta-oe/recipes-multimedia/vlc/vlc.inc
index 00d8663cd4..1fe2d04f21 100644
--- a/meta-oe/recipes-multimedia/vlc/vlc.inc
+++ b/meta-oe/recipes-multimedia/vlc/vlc.inc
@@ -21,65 +21,65 @@ PACKAGES =+ "libvlc-dbg libvlc-dev libvlc"
FILES_libvlc-dev = "${libdir}/lib*.so"
FILES_libvlc-dbg = "\
- ${libdir}/.debug \
- ${libdir}/vlc/meta_engine/.debug \
- ${libdir}/vlc/audio_filter/.debug ${libdir}/vlc/audio_output/.debug \
- ${libdir}/vlc/demux/.debug ${libdir}/vlc/control/.debug \
- ${libdir}/vlc/gui/.debug ${libdir}/vlc/packetizer/.debug \
- ${libdir}/vlc/audio_mixer/.debug ${libdir}/vlc/stream_out/.debug \
- ${libdir}/vlc/mux/.debug ${libdir}/vlc/access/.debug \
- ${libdir}/vlc/visualization/.debug ${libdir}/vlc/access_filter/.debug \
- ${libdir}/vlc/access_output/.debug ${libdir}/vlc/video_output/.debug \
- ${libdir}/vlc/services_discovery/.debug ${libdir}/vlc/video_chroma/.debug \
- ${libdir}/vlc/video_codec/.debug ${libdir}/vlc/video_filter/.debug \
- ${libdir}/vlc/misc/.debug ${libdir}/vlc/codec/.debug \
- "
+ ${libdir}/.debug \
+ ${libdir}/vlc/meta_engine/.debug \
+ ${libdir}/vlc/audio_filter/.debug ${libdir}/vlc/audio_output/.debug \
+ ${libdir}/vlc/demux/.debug ${libdir}/vlc/control/.debug \
+ ${libdir}/vlc/gui/.debug ${libdir}/vlc/packetizer/.debug \
+ ${libdir}/vlc/audio_mixer/.debug ${libdir}/vlc/stream_out/.debug \
+ ${libdir}/vlc/mux/.debug ${libdir}/vlc/access/.debug \
+ ${libdir}/vlc/visualization/.debug ${libdir}/vlc/access_filter/.debug \
+ ${libdir}/vlc/access_output/.debug ${libdir}/vlc/video_output/.debug \
+ ${libdir}/vlc/services_discovery/.debug ${libdir}/vlc/video_chroma/.debug \
+ ${libdir}/vlc/video_codec/.debug ${libdir}/vlc/video_filter/.debug \
+ ${libdir}/vlc/misc/.debug ${libdir}/vlc/codec/.debug \
+"
FILES_libvlc = "${libdir}/lib*.so.*"
FILES_${PN} += "${bindir}/vlc \
- ${datadir}/applications \
- ${datadir}/vlc/ \
- ${datadir}/icons \
- "
+ ${datadir}/applications \
+ ${datadir}/vlc/ \
+ ${datadir}/icons \
+"
-FILES_${PN}-dbg += "${libdir}/vlc/*/.debug ${libdir}/vlc/plugins/*/.debug"
+FILES_${PN}-dbg += "${libdir}/vlc/*/.debug ${libdir}/vlc/plugins/*/.debug"
EXTRA_OECONF = "\
- --enable-dvdread \
- --enable-libtool \
- --with-contrib \
- --enable-run-as-root \
- --disable-wxwidgets \
- --enable-x11 --enable-xvideo \
- --disable-screen --disable-caca \
- --enable-httpd --enable-vlm \
- --enable-freetype \
- --enable-sdl \
- --enable-png \
- --enable-live555 --enable-tremor \
- --enable-v4l2 --enable-v4l --disable-aa --enable-wma --disable-faad \
- --enable-dbus \
- --disable-hal \
- --without-contrib \
- --without-kde-solid \
- --disable-opengl --disable-glx \
- --enable-realrtsp \
- ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \
- ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \
- ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}/uic4 \
+ --enable-dvdread \
+ --enable-libtool \
+ --with-contrib \
+ --enable-run-as-root \
+ --disable-wxwidgets \
+ --enable-x11 --enable-xvideo \
+ --disable-screen --disable-caca \
+ --enable-httpd --enable-vlm \
+ --enable-freetype \
+ --enable-sdl \
+ --enable-png \
+ --enable-live555 --enable-tremor \
+ --enable-v4l2 --enable-v4l --disable-aa --enable-wma --disable-faad \
+ --enable-dbus \
+ --disable-hal \
+ --without-contrib \
+ --without-kde-solid \
+ --disable-opengl --disable-glx \
+ --enable-realrtsp \
+ ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \
+ ac_cv_path_RCC=${STAGING_BINDIR_NATIVE}/rcc4 \
+ ac_cv_path_UIC=${STAGING_BINDIR_NATIVE}/uic4 \
"
do_configure() {
- cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/
- ./bootstrap
- gnu-configize --force
- libtoolize --force
- #autoreconf --force -i
- cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true
- oe_runconf
- rm config.log
- sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config
- sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile
+ cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/
+ ./bootstrap
+ gnu-configize --force
+ libtoolize --force
+ #autoreconf --force -i
+ cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/ || true
+ oe_runconf
+ rm config.log
+ sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config
+ sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile
}