aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-shells/dash/dash_0.5.11.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-shells/dash/dash_0.5.11.2.bb')
-rw-r--r--meta-oe/recipes-shells/dash/dash_0.5.11.2.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-shells/dash/dash_0.5.11.2.bb b/meta-oe/recipes-shells/dash/dash_0.5.11.2.bb
new file mode 100644
index 0000000000..f59e6d1f7a
--- /dev/null
+++ b/meta-oe/recipes-shells/dash/dash_0.5.11.2.bb
@@ -0,0 +1,27 @@
+SUMMARY = "Small and fast POSIX-compliant shell"
+HOMEPAGE = "http://gondor.apana.org.au/~herbert/dash/"
+SECTION = "System Environment/Shells"
+
+LICENSE = "BSD & GPLv2+"
+LIC_FILES_CHKSUM = "file://COPYING;md5=b5262b4a1a1bff72b48e935531976d2e"
+
+inherit autotools update-alternatives
+
+SRC_URI = "http://gondor.apana.org.au/~herbert/${BPN}/files/${BP}.tar.gz"
+SRC_URI[md5sum] = "b9b71c72e40fdc4db9b4ffb81fc3bebc"
+SRC_URI[sha256sum] = "00fb7d68b7599cc41ab151051c06c01e9500540183d8aa72116cb9c742bd6d5f"
+
+EXTRA_OECONF += "--bindir=${base_bindir}"
+
+ALTERNATIVE_${PN} = "sh"
+ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
+ALTERNATIVE_TARGET[sh] = "${base_bindir}/dash"
+ALTERNATIVE_PRIORITY = "10"
+
+pkg_postinst_${PN} () {
+ grep -q "^${base_bindir}/dash$" $D${sysconfdir}/shells || echo ${base_bindir}/dash >> $D${sysconfdir}/shells
+}
+
+pkg_postrm_${PN} () {
+ printf "$(grep -v "^${base_bindir}/dash$" $D${sysconfdir}/shells)\n" > $D${sysconfdir}/shells
+}