aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/espeak/espeak_1.37.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/espeak/espeak_1.37.bb')
-rw-r--r--meta-oe/recipes-support/espeak/espeak_1.37.bb40
1 files changed, 20 insertions, 20 deletions
diff --git a/meta-oe/recipes-support/espeak/espeak_1.37.bb b/meta-oe/recipes-support/espeak/espeak_1.37.bb
index 6cc4cd4107..c7f4b521c3 100644
--- a/meta-oe/recipes-support/espeak/espeak_1.37.bb
+++ b/meta-oe/recipes-support/espeak/espeak_1.37.bb
@@ -13,30 +13,30 @@ TARGET_CC_ARCH += "${LDFLAGS}"
FILES_${PN} += "${datadir}/espeak-data"
do_configure() {
- # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
- cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
+ # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
+ cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
}
do_compile() {
- cd src
- oe_runmake
+ cd src
+ oe_runmake
}
do_install() {
- install -d ${D}${bindir}
- install -d ${D}${libdir}
- install -d ${D}${includedir}
- install -d ${D}${datadir}/espeak-data
-
- # we do not ship "speak" binary though.
- install -m 0755 ${S}/src/espeak ${D}${bindir}
- install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
- oe_libinstall -so -C src libespeak ${D}${libdir}
-
- if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
- # the big-endian phon* files are provided by the package espeak-data
- rm -f ${S}/espeak-data/phon*
- fi
-
- cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
+ install -d ${D}${bindir}
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ install -d ${D}${datadir}/espeak-data
+
+ # we do not ship "speak" binary though.
+ install -m 0755 ${S}/src/espeak ${D}${bindir}
+ install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
+ oe_libinstall -so -C src libespeak ${D}${libdir}
+
+ if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
+ # the big-endian phon* files are provided by the package espeak-data
+ rm -f ${S}/espeak-data/phon*
+ fi
+
+ cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
}