aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb')
-rw-r--r--meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb b/meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb
new file mode 100644
index 0000000000..3ef7bee439
--- /dev/null
+++ b/meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb
@@ -0,0 +1,24 @@
+SUMMARY = "the Git linkable library"
+HOMEPAGE = "http://libgit2.github.com/"
+LICENSE = "GPL-2.0-with-GCC-exception & MIT"
+LIC_FILES_CHKSUM = "file://COPYING;md5=3f2cd5d3cccd71d62066ba619614592b"
+
+DEPENDS = "curl openssl zlib libssh2 libgcrypt"
+
+SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v0.27"
+SRCREV = "3828d7afdd08b595584048e8e4dab6ddd4506ed1"
+
+S = "${WORKDIR}/git"
+
+inherit cmake
+
+EXTRA_OECMAKE = "\
+ -DTHREADSAFE=ON \
+ -DBUILD_CLAR=OFF \
+ -DSHA1_TYPE="builtin" \
+ -DCMAKE_BUILD_TYPE=RelWithDebInfo \
+ -DBUILD_EXAMPLES=OFF \
+ -DLIB_INSTALL_DIR=${libdir} \
+"
+
+BBCLASSEXTEND = "native"