aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/nss/nss_3.64.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/nss/nss_3.64.bb')
-rw-r--r--meta-oe/recipes-support/nss/nss_3.64.bb32
1 files changed, 16 insertions, 16 deletions
diff --git a/meta-oe/recipes-support/nss/nss_3.64.bb b/meta-oe/recipes-support/nss/nss_3.64.bb
index 98be21d40e..c935c6a2ae 100644
--- a/meta-oe/recipes-support/nss/nss_3.64.bb
+++ b/meta-oe/recipes-support/nss/nss_3.64.bb
@@ -9,7 +9,7 @@ HOMEPAGE = "http://www.mozilla.org/projects/security/pki/nss/"
SECTION = "libs"
DEPENDS = "sqlite3 nspr zlib nss-native"
-DEPENDS_class-native = "sqlite3-native nspr-native zlib-native"
+DEPENDS:class-native = "sqlite3-native nspr-native zlib-native"
LICENSE = "(MPL-2.0 & MIT) | (MPL-2.0 & GPL-2.0+ & MIT) | (MPL-2.0 & LGPL-2.1+ & MIT)"
@@ -45,30 +45,30 @@ TDS = "${S}/tentative-dist-staging"
TARGET_CC_ARCH += "${LDFLAGS}"
-CFLAGS_append_class-native = " -D_XOPEN_SOURCE "
+CFLAGS:append:class-native = " -D_XOPEN_SOURCE "
-do_configure_prepend_libc-musl () {
+do_configure:prepend:libc-musl () {
sed -i -e '/-DHAVE_SYS_CDEFS_H/d' ${S}/nss/lib/dbm/config/config.mk
}
-do_configure_prepend_powerpc64le_toolchain-clang () {
+do_configure:prepend:powerpc64le:toolchain-clang () {
sed -i -e 's/\-std=c99/\-std=gnu99/g' ${S}/nss/coreconf/command.mk
}
-do_configure_prepend_powerpc64_toolchain-clang () {
+do_configure:prepend:powerpc64:toolchain-clang () {
sed -i -e 's/\-std=c99/\-std=gnu99/g' ${S}/nss/coreconf/command.mk
}
-do_compile_prepend_class-native() {
+do_compile:prepend:class-native() {
export NSPR_INCLUDE_DIR=${STAGING_INCDIR_NATIVE}/nspr
export NSPR_LIB_DIR=${STAGING_LIBDIR_NATIVE}
}
-do_compile_prepend_class-nativesdk() {
+do_compile:prepend:class-nativesdk() {
export LDFLAGS=""
}
-do_compile_prepend_class-native() {
+do_compile:prepend:class-native() {
# Need to set RPATH so that chrpath will do its job correctly
RPATH="-Wl,-rpath-link,${STAGING_LIBDIR_NATIVE} -Wl,-rpath-link,${STAGING_BASE_LIBDIR_NATIVE} -Wl,-rpath,${STAGING_LIBDIR_NATIVE} -Wl,-rpath,${STAGING_BASE_LIBDIR_NATIVE}"
}
@@ -138,7 +138,7 @@ do_compile() {
do_compile[vardepsexclude] += "SITEINFO_BITS"
-do_install_prepend_class-nativesdk() {
+do_install:prepend:class-nativesdk() {
export LDFLAGS=""
}
@@ -215,7 +215,7 @@ do_install() {
do_install[vardepsexclude] += "SITEINFO_BITS"
-do_install_append() {
+do_install:append() {
# Create empty .chk files for the NSS libraries at build time. They could
# be regenerated at target's boot time.
for file in libsoftokn3.chk libfreebl3.chk libnssdbm3.chk; do
@@ -231,7 +231,7 @@ do_install_append() {
sed -i s:OEINCDIR:${includedir}/nss3:g ${D}${libdir}/pkgconfig/nss.pc
}
-do_install_append_class-target() {
+do_install:append:class-target() {
# It used to call certutil to create a blank certificate with empty password at
# build time, but the checksum of key4.db changes every time when certutil is called.
# It causes non-determinism issue, so provide databases with a blank certificate
@@ -246,7 +246,7 @@ do_install_append_class-target() {
PACKAGE_WRITE_DEPS += "nss-native"
-pkg_postinst_${PN} () {
+pkg_postinst:${PN} () {
for I in $D${libdir}/lib*.chk; do
DN=`dirname $I`
BN=`basename $I .chk`
@@ -259,24 +259,24 @@ pkg_postinst_${PN} () {
}
PACKAGES =+ "${PN}-smime"
-FILES_${PN}-smime = "\
+FILES:${PN}-smime = "\
${bindir}/smime \
"
-FILES_${PN} = "\
+FILES:${PN} = "\
${sysconfdir} \
${bindir} \
${libdir}/lib*.chk \
${libdir}/lib*.so \
"
-FILES_${PN}-dev = "\
+FILES:${PN}-dev = "\
${libdir}/nss \
${libdir}/pkgconfig/* \
${includedir}/* \
"
-RDEPENDS_${PN}-smime = "perl"
+RDEPENDS:${PN}-smime = "perl"
BBCLASSEXTEND = "native nativesdk"