aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/synergy/synergy_1.3.8.bb')
-rw-r--r--meta-oe/recipes-support/synergy/synergy_1.3.8.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/synergy/synergy_1.3.8.bb b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
new file mode 100644
index 0000000000..40efcb17a2
--- /dev/null
+++ b/meta-oe/recipes-support/synergy/synergy_1.3.8.bb
@@ -0,0 +1,22 @@
+DESCRIPTION = "Synergy - control multiple computers with one keyboard and mouse"
+HOMEPAGE = "http://synergy.googlecode.com"
+LIC_FILES_CHKSUM = "file://COPYING;md5=9772a11e3569985855e2ce450e56f991"
+LICENSE = "GPLv2"
+SECTION = "x11/utils"
+
+DEPENDS = "libx11 libxtst"
+
+SRC_URI = "http://synergy.googlecode.com/files/synergy-${PV}-Source.tar.gz"
+
+SRC_URI[md5sum] = "3534c65ecfa6e47d7899c57975442f03"
+SRC_URI[sha256sum] = "0afc83e4ed0b46ed497d4229b2b2854e8d3c581a112f4da05110943edbfacc03"
+
+S = "${WORKDIR}/${PN}-${PV}-Source"
+
+inherit cmake siteinfo
+
+do_install() {
+ install -d ${D}/usr/bin
+ install -m 0755 ${S}/bin/synergy* ${D}/usr/bin/
+}
+