aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-decorator_5.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-decorator_5.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-decorator_5.1.1.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-decorator_5.1.1.bb b/meta-python/recipes-devtools/python/python3-decorator_5.1.1.bb
new file mode 100644
index 0000000000..f330376243
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-decorator_5.1.1.bb
@@ -0,0 +1,20 @@
+SUMMARY = "Python decorator utilities"
+DESCRIPTION = "\
+The aim of the decorator module it to simplify the usage of decorators \
+for the average programmer, and to popularize decorators by showing \
+various non-trivial examples. Of course, as all techniques, decorators \
+can be abused and you should not try to solve every problem with a \
+decorator, just because you can."
+
+LICENSE = "BSD-2-Clause"
+LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=be2fd2007972bf96c08af3293d728b22"
+
+SRC_URI[sha256sum] = "637996211036b6385ef91435e4fae22989472f9d571faba8927ba8253acbc330"
+
+inherit pypi setuptools3
+
+RDEPENDS:${PN} += "\
+ python3-stringold \
+ "
+
+BBCLASSEXTEND = "native nativesdk"