aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb17
1 files changed, 15 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb b/meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb
index fc75e43485..97b3e72364 100644
--- a/meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb
+++ b/meta-python/recipes-devtools/python/python3-lorem_0.1.1.bb
@@ -5,12 +5,25 @@ LIC_FILES_CHKSUM = "file://LICENSE;md5=5301c01b2bcdeedba23645f94db2f179"
SRC_URI[md5sum] = "e3f0064a94c13e19780eb724affdb426"
SRC_URI[sha256sum] = "785f4109a241fc2891e59705e85d065f6e6d3ed6ad91750a8cb54d4f3e59d934"
+SRC_URI += "\
+ file://run-ptest \
+"
+
PYPI_PACKAGE = "lorem"
-inherit pypi setuptools3
+inherit pypi setuptools3 ptest
CLEANBROKEN = "1"
-RDEPENDS_${PN} += " \
+RDEPENDS:${PN} += " \
python3 \
"
+RDEPENDS:${PN}-ptest += " \
+ python3-pytest \
+ python3-unittest-automake-output \
+"
+
+do_install_ptest() {
+ install -d ${D}${PTEST_PATH}/tests
+ cp -rf ${S}/tests/* ${D}${PTEST_PATH}/tests/
+}