aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-pybluez_0.23.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-pybluez_0.23.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-pybluez_0.23.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-pybluez_0.23.bb b/meta-python/recipes-devtools/python/python3-pybluez_0.23.bb
new file mode 100644
index 0000000000..5242059bc6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-pybluez_0.23.bb
@@ -0,0 +1,19 @@
+DESCRIPTION = "Bluetooth Python extension module"
+HOMEPAGE = "https://pybluez.github.io/"
+SECTION = "devel/python"
+
+DEPENDS = "bluez5"
+
+LICENSE = "GPL-2.0"
+LIC_FILES_CHKSUM = "file://COPYING;md5=8a71d0475d08eee76d8b6d0c6dbec543"
+
+SRC_URI[md5sum] = "afbe8429bb82d2c46a3d0f5f4f898f9d"
+SRC_URI[sha256sum] = "c8f04d2e78951eaa9de486b4d49381704e8943d0a6e6e58f55fcd7b8582e90de"
+
+PYPI_PACKAGE = "PyBluez"
+inherit pypi setuptools3
+
+RDEPENDS_${PN} += "\
+ bluez5 \
+ ${PYTHON_PN}-fcntl \
+"