aboutsummaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.1.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.1.bb b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.1.bb
new file mode 100644
index 0000000000..c5524d152e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-u-msgpack-python_2.7.1.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "A portable, lightweight MessagePack serializer and deserializer written in pure Python."
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=9eb4691bcb66360acee473a8cf75f594"
+
+SRC_URI[md5sum] = "8691cea6bc7b44bce6e2115260a54323"
+SRC_URI[sha256sum] = "b7e7d433cab77171a4c752875d91836f3040306bab5063fb6dbe11f64ea69551"
+
+inherit pypi setuptools3 ptest
+
+SRC_URI += " \
+ file://run-ptest \
+"
+
+RDEPENDS_${PN}-ptest += " \
+ ${PYTHON_PN}-pytest \
+"
+
+do_install_ptest() {
+ cp -f ${S}/test_umsgpack.py ${D}${PTEST_PATH}/
+}
+
+RDEPENDS_${PN} += " \
+ ${PYTHON_PN}-datetime \
+"
+
+BBCLASSEXTEND = "native nativesdk"