aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd/oe-core
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd/oe-core')
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend6
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend2
-rw-r--r--meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend2
11 files changed, 26 insertions, 0 deletions
diff --git a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
index 13a2ee453c..d3f4775b7c 100644
--- a/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/avahi/avahi_0.6.31.bbappend
@@ -3,6 +3,8 @@ PRINC := "${@int(PRINC) + 2}"
inherit systemd
RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "avahi-daemon.service"
SYSTEMD_AUTO_ENABLE = "enable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
index 752e6c1951..495fffad21 100644
--- a/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/bluez/bluez4_4.101.bbappend
@@ -5,5 +5,7 @@ inherit systemd
EXTRA_OECONF += "--with-systemdunitdir=${systemd_unitdir}/system/"
RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "bluetooth.service"
SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
index 96a428f1da..61292adde1 100644
--- a/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/connman/connman_1.12.bbappend
@@ -1,4 +1,6 @@
PRINC := "${@int(PRINC) + 2}"
RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "connman.service"
diff --git a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
index d3a322ae7f..5fbe857065 100644
--- a/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/dhcp/dhcp_4.2.5.bbappend
@@ -14,8 +14,14 @@ FILES_dhcp-server += "${systemd_unitdir}/system/dhcpd.service"
FILES_dhcp-relay += "${systemd_unitdir}/system/dhrelay.service"
FILES_dhcp-client += "${systemd_unitdir}/system/dhclient.service"
RPROVIDES_dhcp-server += "dhcp-server-systemd"
+RREPLACES_dhcp-server += "dhcp-server-systemd"
+RCONFLICTS_dhcp-server += "dhcp-server-systemd"
RPROVIDES_dhcp-relay += "dhcp-relay-systemd"
+RREPLACES_dhcp-relay += "dhcp-relay-systemd"
+RCONFLICTS_dhcp-relay += "dhcp-relay-systemd"
RPROVIDES_dhcp-client += "dhcp-client-systemd"
+RREPLACES_dhcp-client += "dhcp-client-systemd"
+RCONFLICTS_dhcp-client += "dhcp-client-systemd"
SRC_URI += "file://dhcpd.service \
file://dhclient.service \
diff --git a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
index 94fce48a55..914117afb7 100644
--- a/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/ofono/ofono_1.12.bbappend
@@ -3,5 +3,7 @@ PRINC := "${@int(PRINC) + 2}"
inherit systemd
RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "ofono.service"
SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
index 0d1bb56e85..fe61a89671 100644
--- a/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/openssh/openssh_6.1p1.bbappend
@@ -6,6 +6,8 @@ SYSTEMD_PACKAGES = "openssh-sshd"
SYSTEMD_SERVICE_openssh-sshd = "sshd.socket"
FILES_openssh-sshd += "${systemd_unitdir}/system/sshd.socket"
RPROVIDES_openssh-sshd += "openssh-sshd-systemd"
+RREPLACES_openssh-sshd += "openssh-sshd-systemd"
+RCONFLICTS_openssh-sshd += "openssh-sshd-systemd"
inherit systemd
diff --git a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
index 784fc1f47c..b7ab2a4de5 100644
--- a/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/portmap/portmap_6.0.bbappend
@@ -5,6 +5,8 @@ PRINC := "${@int(PRINC) + 2}"
inherit systemd
RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "portmap.service"
SYSTEMD_AUTO_ENABLE = "disable"
diff --git a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
index dcd9b84e8e..cffb8985b9 100644
--- a/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
+++ b/meta-systemd/oe-core/recipes-connectivity/wpa-supplicant/wpa-supplicant_2.0.bbappend
@@ -1,3 +1,5 @@
PRINC := "${@int(PRINC) + 4}"
RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
diff --git a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
index 12a9823c80..fae15a0548 100644
--- a/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
+++ b/meta-systemd/oe-core/recipes-core/util-linux/util-linux_2.22.2.bbappend
@@ -5,4 +5,6 @@ PRINC := "${@int(PRINC) + 2}"
SYSTEMD_UNITDIR = "${systemd_unitdir}/system"
EXTRA_OECONF += "--enable-socket-activation --with-systemdsystemunitdir=${SYSTEMD_UNITDIR}"
RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "uuidd.socket"
diff --git a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
index dc06af9a51..dd1eacff74 100644
--- a/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/cronie/cronie_1.4.9.bbappend
@@ -6,6 +6,8 @@ PRINC := "${@int(PRINC) + 4}"
inherit systemd
RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "crond.service"
SRC_URI += "file://crond.service"
diff --git a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
index b6ec2aa01a..6dded402e0 100644
--- a/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
+++ b/meta-systemd/oe-core/recipes-extended/lighttpd/lighttpd_1.4.32.bbappend
@@ -7,6 +7,8 @@ inherit systemd
SRC_URI += "file://lighttpd.service"
RPROVIDES_${PN} += "${PN}-systemd"
+RREPLACES_${PN} += "${PN}-systemd"
+RCONFLICTS_${PN} += "${PN}-systemd"
SYSTEMD_SERVICE_${PN} = "lighttpd.service"
do_install_append() {