aboutsummaryrefslogtreecommitdiffstats
path: root/meta-systemd
diff options
context:
space:
mode:
Diffstat (limited to 'meta-systemd')
-rw-r--r--meta-systemd/classes/systemd.bbclass16
-rw-r--r--meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bbappend (renamed from meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bbappend)0
-rw-r--r--meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_git.bbappend14
-rw-r--r--meta-systemd/recipes-core/systemd/systemd-compat-units.bb2
-rw-r--r--meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service2
5 files changed, 12 insertions, 22 deletions
diff --git a/meta-systemd/classes/systemd.bbclass b/meta-systemd/classes/systemd.bbclass
index 4036f91cad..96d7f8f559 100644
--- a/meta-systemd/classes/systemd.bbclass
+++ b/meta-systemd/classes/systemd.bbclass
@@ -2,6 +2,8 @@ DEPENDS_append = " systemd-systemctl-native"
SYSTEMD_AUTO_ENABLE ??= "enable"
+SYSTEMD_AUTO_RRECOMMENDS ??= "enable"
+
systemd_postinst() {
OPTS=""
@@ -208,12 +210,14 @@ python populate_packages_prepend () {
if len(rdepends_arr) == 0 and pkg_systemd != '${PN}' and not pkg_systemd_base in rdepends:
rdepends = '%s %s' % (rdepends, pkg_systemd_base)
d.setVar('RDEPENDS_' + pkg_systemd, rdepends)
- # RRECOMMENDS_${pkg_systemd_base} += pkg_systemd systemd
- rrecommends = d.getVar('RRECOMMENDS_' + pkg_systemd_base, 1) or ""
- # not rrecommending myself AND avoid double entries
- if pkg_systemd != pkg_systemd_base and not pkg_systemd in rrecommends.split():
- rrecommends = '%s %s' % (rrecommends, pkg_systemd)
- d.setVar('RRECOMMENDS_' + pkg_systemd_base, rrecommends)
+ auto_rrecommends = d.getVar('SYSTEMD_AUTO_RRECOMMENDS', 1) or 'enable'
+ if auto_rrecommends == 'enable':
+ # RRECOMMENDS_${pkg_systemd_base} += pkg_systemd systemd
+ rrecommends = d.getVar('RRECOMMENDS_' + pkg_systemd_base, 1) or ""
+ # not rrecommending myself AND avoid double entries
+ if pkg_systemd != pkg_systemd_base and not pkg_systemd in rrecommends.split():
+ rrecommends = '%s %s' % (rrecommends, pkg_systemd)
+ d.setVar('RRECOMMENDS_' + pkg_systemd_base, rrecommends)
# run all modifications once when creating package
if os.path.exists('${D}'):
diff --git a/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bbappend b/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bbappend
index 9504761574..9504761574 100644
--- a/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.5.bbappend
+++ b/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_3.7.bbappend
diff --git a/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_git.bbappend b/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_git.bbappend
deleted file mode 100644
index 1026e220f6..0000000000
--- a/meta-systemd/meta-oe/recipes-navigation/gpsd/gpsd_git.bbappend
+++ /dev/null
@@ -1,14 +0,0 @@
-PRINC := "${@int(PRINC) + 1}"
-
-inherit systemd
-
-SYSTEMD_PACKAGES = "${PN}-systemd"
-SYSTEMD_SERVICE = "${PN}.socket"
-SYSTEMD_OESCONS = "true"
-
-do_install_append() {
- #support for systemd
- install -d ${D}${systemd_unitdir}/system/
- install -m 0644 ${S}/systemd/${PN}.service ${D}${systemd_unitdir}/system/${PN}.service
- install -m 0644 ${S}/systemd/${PN}.socket ${D}${systemd_unitdir}/system/${PN}.socket
-}
diff --git a/meta-systemd/recipes-core/systemd/systemd-compat-units.bb b/meta-systemd/recipes-core/systemd/systemd-compat-units.bb
index aefd6a758b..6b6b4dda98 100644
--- a/meta-systemd/recipes-core/systemd/systemd-compat-units.bb
+++ b/meta-systemd/recipes-core/systemd/systemd-compat-units.bb
@@ -3,7 +3,7 @@ DESCRIPTION = "Units to make systemd work better with existing sysvinit scripts"
LICENSE = "MIT"
LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3b58"
-PR = "r17"
+PR = "r18"
inherit allarch
diff --git a/meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service b/meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service
index 879a25157b..da6fe76a38 100644
--- a/meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service
+++ b/meta-systemd/recipes-core/systemd/systemd-compat-units/run-postinsts.service
@@ -2,7 +2,7 @@
Description=Run pending postinsts
DefaultDependencies=no
ConditionPathExists=|/etc/rcS.d/S98run-postinsts
-After=remount-rootfs.service
+After=remount-rootfs.service tmp.mount
Before=sysinit.target
[Service]