aboutsummaryrefslogtreecommitdiffstats
path: root/meta-webserver/recipes-httpd/hiawatha/hiawatha_10.10.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-webserver/recipes-httpd/hiawatha/hiawatha_10.10.bb')
-rw-r--r--meta-webserver/recipes-httpd/hiawatha/hiawatha_10.10.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/meta-webserver/recipes-httpd/hiawatha/hiawatha_10.10.bb b/meta-webserver/recipes-httpd/hiawatha/hiawatha_10.10.bb
new file mode 100644
index 0000000000..ed3df19390
--- /dev/null
+++ b/meta-webserver/recipes-httpd/hiawatha/hiawatha_10.10.bb
@@ -0,0 +1,64 @@
+SUMMARY = "Lightweight secure web server"
+HOMEPAGE = "http://www.hiawatha-webserver.org"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=751419260aa954499f7abaabaa882bbe"
+DEPENDS = "libxml2 libxslt virtual/crypt"
+
+SECTION = "net"
+
+SRC_URI = "http://hiawatha-webserver.org/files/${BP}.tar.gz \
+ file://hiawatha-init \
+ file://hiawatha.service "
+
+SRC_URI[md5sum] = "3bf2c12c7037ecc3dfdbec72e7a2f04f"
+SRC_URI[sha256sum] = "b5e46f5757fa647e77d21d24f7eea912d59f26a75558cba780b45c1c3a33a4d9"
+
+INITSCRIPT_NAME = "hiawatha"
+INITSCRIPT_PARAMS = "defaults 70"
+
+SYSTEMD_SERVICE_${PN} = "hiawatha.service"
+
+inherit cmake update-rc.d systemd
+
+EXTRA_OECMAKE = " -DENABLE_IPV6=OFF \
+ -DENABLE_CACHE=OFF \
+ -DENABLE_DEBUG=OFF \
+ -DENABLE_TLS=OFF \
+ -DENABLE_TOOLKIT=OFF \
+ -DENABLE_CHROOT=OFF \
+ -DENABLE_XSLT=ON \
+ -DENABLE_TOMAHAWK=OFF \
+ -DCMAKE_INSTALL_MANDIR=${mandir} \
+ -DCMAKE_INSTALL_BINDIR=${bindir} \
+ -DCMAKE_INSTALL_SBINDIR=${sbindir} \
+ -DCMAKE_INSTALL_SYSCONFDIR=${sysconfdir} \
+ -DCMAKE_INSTALL_LIBDIR=${libdir} \
+ -DCMAKE_INSTALL_FULL_LOCALSTATEDIR=${localstatedir}"
+
+do_install_append() {
+ # Copy over init script and sed in the correct sbin path
+ sed -i 's,sed_sbin_path,${sbindir},' ${WORKDIR}/hiawatha-init
+ mkdir -p ${D}${sysconfdir}/init.d
+ install -m 0755 ${WORKDIR}/hiawatha-init ${D}${sysconfdir}/init.d/hiawatha
+
+ # configure php-fcgi to have a working configuration
+ # by default if php is installed
+ echo "Server = ${bindir}/php-cgi ; 2 ; 127.0.0.1:2005 ; nobody:nobody ; ${sysconfdir}/php/hiawatha-php5/php.ini" >> ${D}${sysconfdir}/hiawatha/php-fcgi.conf
+
+ if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
+ install -d ${D}/${systemd_unitdir}/system
+ install -m 644 ${WORKDIR}/hiawatha.service ${D}/${systemd_unitdir}/system
+ fi
+
+ rmdir --ignore-fail-on-non-empty "${D}${localstatedir}" "${D}${localstatedir}/run"
+}
+
+CONFFILES_${PN} = " \
+ ${sysconfdir}/hiawatha/cgi-wrapper.conf \
+ ${sysconfdir}/hiawatha/hiawatha.conf \
+ ${sysconfdir}/hiawatha/index.xslt \
+ ${sysconfdir}/hiawatha/mimetype.conf \
+ ${sysconfdir}/hiawatha/php-fcgi.conf \
+"
+
+FILES_${PN}-dev = "${libdir}/hiawatha/*${SOLIBSDEV}"