aboutsummaryrefslogtreecommitdiffstats
path: root/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.16.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-xfce/recipes-xfce/xfwm4/xfwm4_4.16.1.bb')
-rw-r--r--meta-xfce/recipes-xfce/xfwm4/xfwm4_4.16.1.bb8
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.16.1.bb b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.16.1.bb
index 2cbfdadd5f..f4a78f1adf 100644
--- a/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.16.1.bb
+++ b/meta-xfce/recipes-xfce/xfwm4/xfwm4_4.16.1.bb
@@ -20,18 +20,18 @@ PACKAGECONFIG[epoxy] = "--enable-epoxy,--disable-epoxy,libepoxy"
PACKAGECONFIG[xpresent] = "--enable-xpresent,--disable-xpresent,libxpresent"
PACKAGECONFIG[startup-notification] = "--enable-startup-notification,--disable-startup-notification,startup-notification"
-python populate_packages_prepend () {
+python populate_packages:prepend () {
themedir = d.expand('${datadir}/themes')
do_split_packages(d, themedir, '^(.*)', 'xfwm4-theme-%s', 'XFWM4 theme %s', allow_dirs=True)
}
PACKAGES_DYNAMIC += "^xfwm4-theme-.*"
-ALTERNATIVE_${PN} = "x-window-manager"
+ALTERNATIVE:${PN} = "x-window-manager"
ALTERNATIVE_TARGET[x-window-manager] = "${bindir}/xfwm4"
ALTERNATIVE_PRIORITY[x-window-manager] = "30"
-RDEPENDS_${PN} = "xfwm4-theme-default"
-FILES_${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \
+RDEPENDS:${PN} = "xfwm4-theme-default"
+FILES:${PN} += "${libdir}/xfce4/xfwm4/helper-dialog \
${datadir}/xfwm4/defaults \
"