aboutsummaryrefslogtreecommitdiffstats
path: root/meta-networking/recipes-support
Commit message (Collapse)AuthorAgeFilesLines
* tcpdump: Fix CVE-2017-16808thud-nextthudPeiran Hong2019-10-052-0/+62
| | | | | | | | | | | | | | | | | | | | | | | | | | | Backport selected parts of three upstream commits to fix CVE-2017-16808 where tcpdump 4.9.2 has a heap-based buffer over-read. Upstream-Status: Backport [ several ] Upstream commits fully backported: 46aead6 [CVE-2017-16808/AoE: Add a missing bounds check] Upstream commits partially backported: 7068209 [Use nd_ types in 802.x and FDDI headers.] 84ef17a [Replace ND_TTEST2()/ND_TCHECK2() macros by macros using pointers (1/n)] 46aead6 fixes the vulnerability and requires two macros defined in 7068209 and 84ef17a, which are committed after the release of 4.9.2. Only the definition of the macros are taken from the two commits as they impact a wide range of code and are difficult to integrate. CVE: CVE-2017-16808 Signed-off-by: Peiran Hong <peiran.hong@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* wireshark: Update to 2.6.10 for security fixes.Armin Kuster2019-09-041-2/+2
| | | | | | | | | | | | | | | | | | | | | | | | | | | Source: wireshark.org MR: 99742, 99743, 99744, 99745, 99746 99747, 99742, 99748, 99062 Type: Security Fix Disposition: Backport from wireshark.org ChangeID: d9a2014ea6271a58633cea8899b63257b8b03cd3 Description: Bug fix update only updates. 2.8.10: wnpa-sec-2019-20 ASN.1 BER and related dissectors crash. Bug 15870. CVE-2019-13619. 2.8.9: wnpa-sec-2019-19 Wireshark dissection engine crash. Bug 15778. CVE-2019-12295 2.6.8: wnpa-sec-2019-09 NetScaler file parser crash. Bug 15497. CVE-2019-10895. wnpa-sec-2019-10 SRVLOC dissector crash. Bug 15546. CVE-2019-10899. wnpa-sec-2019-14 GSS-API dissector crash. Bug 15613. CVE-2019-10894. wnpa-sec-2019-15 DOF dissector crash. Bug 15617. CVE-2019-10896. wnpa-sec-2019-17 LDSS dissector crash. Bug 15620. CVE-2019-10901. wnpa-sec-2019-18 DCERPC SPOOLSS dissector crash. Bug 15568. CVE-2019-10903. Signed-off-by: Armin Kuster <akuster@mvista.com>
* ntp: upgrade 4.2.8p12 -> 4.2.8p13Andrej Valek2019-05-251-3/+3
| | | | | | | | | | | License has been changed due to reformatting, no new stuff added. Bug fix only update include security fixes: CVE-2019-8936 Signed-off-by: Andrej Valek <andrej.valek@siemens.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster@mvista.com>
* Split ntpq into an own packageAdrian Bunk2019-03-241-1/+4
| | | | | | | | ntpq is the standard query program for ntp, but ntp-utils depends on perl. Signed-off-by: Adrian Bunk <bunk@stusta.de> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* wireshark: update to 2.6.6Armin Kuster2019-02-041-2/+2
| | | | | | | | | | | | | | | includes: wnpa-sec-2019-01 The 6LoWPAN dissector could crash. Bug 15217. CVE-2019-5716. wnpa-sec-2019-02 The P_MUL dissector could crash. Bug 15337. CVE-2019-5717. wnpa-sec-2019-03 The RTSE dissector and other dissectors could crash. Bug 15373. CVE-2019-5718. wnpa-sec-2019-04 The ISAKMP dissector could crash. Bug 15374. CVE-2019-5719. For more info see: https://www.wireshark.org/docs/relnotes/wireshark-2.6.6.html Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* wireshark: upgrade to 2.6.5Hong Liu2019-02-041-2/+2
| | | | | | | | 1.Upgrade wireshark from 2.6.4 to 2.6.5. Signed-off-by: Hong Liu <hongl.fnst@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geoip: update SRC_URIChangqing Li2018-12-221-4/+4
| | | | | | | | | | previous database on maxmind website will be removed from January 2, 2019. and also we met checksum weekly change problem, so update the SRC_URI to http://sources.openembedded.org/ Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geoip: update geolite database checksumChangqing Li2018-12-221-12/+14
| | | | | | | | | Geolite database checksum changed today, so update it to the lastest one. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geoip: add downloadfilename for geoip database filesChangqing Li2018-12-221-12/+12
| | | | | | | | | | | | | | | previous change of checksum don't trigger archive to re-downloaded, , which will cause checksum mismatch. add downloadfilename to trigger re-download. 1. for user with PREMIRROR, another benefit is it can still compile success event upstream checksum change frequently. 2. but for user don't use PREMIRROR, if upstream checksum changed, still might have checksum mismatch problem. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* ntp: Reproducible build: Use fixed path to posix shelldouglas.royds2018-11-152-0/+16
| | | | | | | | | | | | | | | At configure time, the ntp build goes looking on the build machine for a posix shell, using `which` to find it. Under OE, it settles on hosttools/bash, resulting in this build host path being written into several binaries. This did not affect the Debian reproducibility project, presumably because it consistently found bash at /bin/bash. Don't go looking, just use a fixed path to /bin/sh instead. Upstream-Status: Submitted http://bugs.ntp.org/show_bug.cgi?id=3551 Signed-off-by: Douglas Royds <douglas.royds@taitradio.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* ntp: Reproducible build: Respect SOURCE_DATE_EPOCHdouglas.royds2018-11-152-0/+17
| | | | | | | | | | | | | | | If a SOURCE_DATE_EPOCH is set in the environment, use that date in the build version string, otherwise use the current build date. See https://reproducible-builds.org/docs/source-date-epoch/ Should GNU date options fail, try BSD date options as a fall-back. This patch can potentially be pushed upstream for use on Mac OSX or OpenBSD, though it has not been tested on OSX or any BSD platform. Upstream-Status: Submitted http://bugs.ntp.org/show_bug.cgi?id=3550 Signed-off-by: Douglas Royds <douglas.royds@taitradio.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geoip: update GeoLite Database checksumChangqing Li2018-11-151-4/+4
| | | | | | | | | GeoLite Database checksum changed again recently, so update it. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* curlpp: Fix packaging and reference to licenseRobert Tiemann2018-11-151-16/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | This patch fixes three issues: 1. The recipe used "libcurlpp" for its package base name. It defined PACKAGES and corresponding package contents manually, but the non-standard naming led to an error message when trying to depend on it (nothing provides curlpp needed by curlpp-dev). See also https://lists.yoctoproject.org/pipermail/poky/2018-February/011236.html. Fixed by removing PACKAGES and corresponding FILES_*, relying on automatic packaging now. 2. Upstream ships a license file (MIT), which is referenced by the recipe now (instead of the stock COPYING.MIT file). 3. There was a do_install_append() function which patched the installed curlpp.pc file. Since it seemed to be of no use, it was removed. Signed-off-by: Robert Tiemann <rtie@gmx.de> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* netcat-openbsd: update SRC_URIChangqing Li2018-11-151-2/+2
| | | | | | | | update SRC_URI since previous is not valid now Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* geoip: update md5sum and sha256sumChangqing Li2018-11-151-8/+8
| | | | | | | | | Geolite database update periodically, md5sum and sha256sum have changed, update them Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* openipmi: not install .pyc and .pyo filesKai Kang2018-10-192-0/+27
| | | | | | | | | | | | | openipmi load swig/python/.libs/_OpenIPMI.so to create .pyc and .pyo files. It fails when multilib is enable: | ImportError: .../lib32-openipmi/2.0.25-r0/OpenIPMI-2.0.25/swig/python/.libs/_OpenIPMI.so: | wrong ELF class: ELFCLASS32 Don't compile and install .pyc and .pyo files to fix the failure. Signed-off-by: Kai Kang <kai.kang@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* strongswan: upgrade to 5.7.1Qi.Chen@windriver.com2018-10-161-2/+2
| | | | | Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* wireshark: update to 2.6.4Yi Zhao2018-10-152-27/+3
| | | | | | | | | | | | | | | | | | * Update SRC_URI In https://1.as.dl.wireshark.org/src/, it only keep the latest release. Switch to https://1.as.dl.wireshark.org/src/all-versions/ to make sure the old release can be found. * Drop patch fix-fatal-no-names-found-git-error.patch Actually this piece of code should not be invoked when build from tarball. But in previous releases the code will be performed when building native package if host with rpmbuild and git installed, which will cause a configure error. This issue has been fixed in 2.6.4: commit 4fbc017e80d6d11f8c26cad12d883fd6da9d3504 CMake: Fix build from tarball under certain conditions Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* c-ares: add nativesdk to BBCLASSEXTENDHiram Lew2018-10-101-1/+1
| | | | | | | | | grpc won't build as nativesdk package since it depends on nativesdk-c-ares. Signed-off-by: Hiram Lew <lew@avast.com> Signed-off-by: Jan Kaisrlik <jan.kaisrlik@avast.com> Signed-off-by: Bartosz Golaszewski <bgolaszewski@baylibre.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* openvpn: update to 2.4.6Armin Kuster2018-10-091-3/+3
| | | | | | | | | | LIC_FILES_CHKSUM changed do to "Update copyright to include 2018 plus company name change" includes: CVE-2018-9336 see: https://community.openvpn.net/openvpn/wiki/ChangesInOpenvpn24 Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* openvpn: enable sysvinitArmin Kuster2018-10-081-1/+5
| | | | | | | add INITSCRIPT Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* tinyproxy: Refresh patchesKhem Raj2018-09-291-6/+15
| | | | | | Fixes warnings reported by devtool Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libldb: add pam to REQUIRED_DISTRO_FEATURESMartin Jansa2018-09-271-1/+2
| | | | | | | | | | | | | | | | * dependency on samba was added recently in: libldb: Add samba to rdeps for pyldb so now we need to match samba restriction to prevent: ERROR: Nothing RPROVIDES 'samba' (but meta-oe/meta-networking/recipes-support/libldb/libldb_1.4.1.bb RDEPENDS on or otherwise requires it) samba was skipped: missing required distro feature 'pam' (not in DISTRO_FEATURES) NOTE: Runtime target 'samba' is unbuildable, removing... Missing or unbuildable dependency chain was: ['samba'] ERROR: Required build target 'meta-world-pkgdata' has no buildable providers. Missing or unbuildable dependency chain was: ['meta-world-pkgdata', 'libldb', 'samba'] Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* netperf: Fix build error on muslKhem Raj2018-09-262-4/+56
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ipsec-tools: support openssl 1.1.xHongxu Jia2018-09-252-1/+1088
| | | | | | | | Long time no maintain from upstream since 2015, backport a fix from openwrt Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* lksctp-tools: fix ptest Segmentation faultMingli Yu2018-09-252-0/+45
| | | | | | | | | | | | | | | | | Initialize the variable event properly to fix the below Segmentation fault: # cd /usr/lib64/lksctp-tools/ptest # ./test_1_to_1_events test_1_to_1_events.c 1 PASS : COMM_UP notification on client socket - SUCCESS test_1_to_1_events.c 2 PASS : COMM_UP notification on server socket - SUCCESS test_1_to_1_events.c 3 BROK : Got a datamsg, expecting notification DUMP_CORE sctputil.c: 187 [ 1468.733938] test_1_to_1_eve[2376]: segfault at 0 ip 0000561a4a3d5079 sp 00007ffd49101580 error 6 in test_1_to_1_events[561a4a3d4000+2000] [ 1468.734479] Code: ff bf 0a 00 00 00 e8 e6 ef ff ff b9 c9 00 00 00 48 8d 15 61 13 00 00 bf 01 00 00 00 31 c0 48 8d 35 c7 0f 00 00 e8 97 f0 Segmentation fault Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libldb: Add samba to rdeps for pyldbKhem Raj2018-09-241-1/+1
| | | | | | | | Fixes ERROR: QA Issue: pyldb rdepends on samba, but it isn't a build dependency, missing samba in DEPENDS or PACKAGECONFIG? [build-deps] Signed-off-by: Khem Raj <raj.khem@gmail.com>
* tinyproxy: upgrade to version 1.10.0Jacobo Aragunde Pérez2018-09-243-25/+26
| | | | | | | | | | Highlights of this upgrade: * tinyproxy binary is not installed to /usr/sbin now. * removed a deprecated configure parameter. * reworked disable-documentation.patch. Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libtalloc: split one dpg packageHongxu Jia2018-09-171-3/+3
| | | | | | | | | | | Multiple -dbg packages per recipe is not encouraged, and only one is recommended and the code only works properly in some cases for one. Add RPROVIDES_${PN}-dbg to be compatiable with previous dbg packages requiring. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libtdb: split one dpg packageHongxu Jia2018-09-171-2/+3
| | | | | | | | | | | Multiple -dbg packages per recipe is not encouraged, and only one is recommended and the code only works properly in some cases for one. Add RPROVIDES_${PN}-dbg to be compatiable with previous dbg packages requiring. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* libtevent: split one dpg packageHongxu Jia2018-09-171-2/+3
| | | | | | | | | | | Multiple -dbg packages per recipe is not encouraged, and only one is recommended and the code only works properly in some cases for one. Add RPROVIDES_${PN}-dbg to be compatiable with previous dbg packages requiring. Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* stunnel: update 5.35 -> 5.49Andre McCurdy2018-09-142-26/+37
| | | | | | | | | | | | | | | - Update LIC_FILES_CHKSUM due to change in COPYING copyright year - Fix dependency on libnsl2 (previously provided indirectly by tcp-wrappers) - Drop obsolete dependency on zlib - Add PACKAGECONFIG control for libwrap - Move legacy stunnel3 wrapper (and its perl dependency) into separate package For a full list of changes between stunnel 5.35 and 5.49 see: https://www.stunnel.org/sdf_ChangeLog.html Signed-off-by: Andre McCurdy <armccurdy@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* spice: cleanup leftover patch from upgrade to 0.13.90Martin Jansa2018-09-142-37/+0
| | | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* spice: fix compile error on 32bit systemChangqing Li2018-09-142-0/+37
| | | | | | | | | | Fix below compile error on 32bit system, since input argument is uLong, but use format %d: format '%d' expects argument of type 'int', but argument 6 has type 'long unsigned int' [-Werror=format=] Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* nbd: Upgrade to nbd 3.17Andrew Bresticker2018-09-121-2/+2
| | | | | | | | Upgrade to a more recent version of nbd that supports listening on multiple IP addresses. Signed-off-by: Andrew Bresticker <abrestic@waymo.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ipsec-tools: Depend on openssl10Khem Raj2018-09-081-1/+1
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* uftp: Upgrade to 4.9.8Khem Raj2018-09-081-2/+2
| | | | | | Fixes build with OpenSSL 1.1.x Signed-off-by: Khem Raj <raj.khem@gmail.com>
* fetchmail: Fix build with OpenSSL 1.1.xKhem Raj2018-09-082-1/+1579
| | | | | | Backport a patch from Debian Signed-off-by: Khem Raj <raj.khem@gmail.com>
* esmtp: add sendmail to ALTERNATIVE_${PN}Mingli Yu2018-09-051-1/+3
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | There are several packages provide ${sbindir}/sendmail and should add sendmail to ALTERNATIVE_${PN} to make it work well. And the sendmail is removed from ALTERNATIVE_${PN} in below commit: === commit 7b500488115c67d657312135b48027a1c26e0955 Author: Lei Maohui <leimaohui@cn.fujitsu.com> Date: Fri Aug 17 18:19:53 2018 -0700 postfix,esmtp: Fix confilct error in do_rootfs Error: Transaction check error: file /usr/bin/mailq conflicts between attempted installs of esmtp-1.2-r0.x86_64 and postfix-3.2.2-r0.x86_64 file /usr/bin/newaliases conflicts between attempted installs of esmtp-1.2-r0.x86_64 and postfix-3.2.2-r0.x86_64 Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> === Add it back to make sendmail works normally Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* spice: Upgrade 0.14.0 -> 0.14.1zhe.he@windriver.com2018-09-051-4/+7
| | | | | | | | | | | Adjust location of spice-common source as new spice asks spice-common to be put under "subprojects" directory. Disable -Werror when building with clang for the moment. Some non-trivial changes need to be made to fix the warnings clang give. Signed-off-by: He Zhe <zhe.he@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* lksctp-tools: Upgrade to 1.0.18Mingli Yu2018-09-047-3/+276
| | | | | | | | | | | | | | | | | inherit autotools-brokensep to fix the gap between ${S} and ${B} Backport 6 patches from master to fix build issue[https://github.com/sctp/lksctp-tools/compare/lksctp-tools-1.0.18...master] | WARNING: lksctp-tools-1.0.18+gitAUTOINC+1b077af62d-r0 do_package: QA Issue: lksctp-tools: Files/directories were installed but not shipped in: | /usr/lib64/libsctp.so.1.0.17 | /usr/lib64/lksctp-tools/libwithsctp.so.1.0.17 | -- Looking for sctp_connectx - not found[when build freediameter which depends on lksctp-tools] Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ndisc6: Do not use gold linker and disable rpathKhem Raj2018-08-301-5/+2
| | | | | | It builds with clang just fine so remove pinning it to gcc-only recipe Signed-off-by: Khem Raj <raj.khem@gmail.com>
* memcached: Update to 1.5.10Khem Raj2018-08-291-2/+2
| | | | Signed-off-by: Khem Raj <raj.khem@gmail.com>
* drbd-utils: fix usrmerge install pathMingli Yu2018-08-281-1/+12
| | | | | | | | | | | | | | | | | | | | | Install the files under folder /usr/lib/drbd to instead of /lib/drbd and also /usr/lib/udev to instead of /lib/udev/ when usrmerge enabled to fix below issue: | WARNING: drbd-utils-9.5.0-r0 do_package: QA Issue: drbd-utils: Files/directories were installed but not shipped in any package: /lib/drbd/drbdsetup-84 /lib/drbd/drbdadm-83 /lib/drbd/drbdsetup-83 /lib/drbd/drbdadm-84 /lib/drbd/drbd | Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_insta. | drbd-utils: 5 installed and not shipped files. [installed-vs-shipped] | ERROR: QA Issue: drbd-utils-dbg package is not obeying usrmerge distro feature. /lib should be relocated to /usr. [usrmerge] Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ntp: Upgrade 4.2.8p11 -> 4.2.8p12Changqing Li2018-08-211-2/+3
| | | | | | | | | | | | | 1. Upgrade ntp to 4.2.8p12 2. Disable sntp service by default. Default NTPSERVER in config sntp is "ntpserver.example.org", just an example, not a valid address, if enable sntp service by default, it will startup failed during boot. It should be enabled after user set the correct config for sntp according to current config of ntpd. Signed-off-by: Changqing Li <changqing.li@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* postfix,esmtp: Fix confilct error in do_rootfsLei Maohui2018-08-191-3/+3
| | | | | | | | | Error: Transaction check error: file /usr/bin/mailq conflicts between attempted installs of esmtp-1.2-r0.x86_64 and postfix-3.2.2-r0.x86_64 file /usr/bin/newaliases conflicts between attempted installs of esmtp-1.2-r0.x86_64 and postfix-3.2.2-r0.x86_64 Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* ipvsadm: fix usrmerge install pathMingli Yu2018-08-191-0/+1
| | | | | | | | | | Update SBIN to fix below error when usrmerge enabled in DISTRO_FEATURES. ERROR: QA Issue: ipvsadm-dbg package is not obeying usrmerge distro feature. /sbin should be relocated to /usr. [usrmerge] Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
* wireshark_2.6.2.bb: Add depedency to bison-nativeManjukumar Matha2018-08-191-1/+1
| | | | | | | | | | | | | | | | Fix the following do_configure failure | CMake Error at wireshark-native/1_2.6.2-r0/recipe-sysroot-native/usr/share/cmake-3.11/Modules/FindPackageHandleStandardArgs.cmake:137 (message): | Could NOT find YACC (missing: YACC_EXECUTABLE) | Call Stack (most recent call first): Add depedency to bison-native which provides byacc to prevent the above failure Signed-off-by: Manjukumar Matha <manjukumar.harthikote-matha@xilinx.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
* yp-tools: Add dep on virtual/cryptKhem Raj2018-08-131-1/+1
| | | | | | | | needed with glibc 2.28+ where crypt has moved into independent recipe Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Joe MacDonald <joe_macdonald@mentor.com>
* ifenslave: inherit manpages instead of adding man to RDEPENDS_${PN}Martin Jansa2018-08-111-2/+2
| | | | | | | * set MAN_PKG because this recipe explicitly packages mandir in PN instead of PN-doc Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>