aboutsummaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-navigation
Commit message (Collapse)AuthorAgeFilesLines
* gpsd: add missing python-pygps RDEPENDSMartin Kelly2018-02-011-1/+8
| | | | | | | | | | | | Several runtime dependencies are missing from python-pygps. You can verify this by adding gps-utils to an image and running gpsfake, which will fail with python import errors. With this patch, gpsfake works correctly. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit d6c40bcaef556e3c67c6214d8fb6933ac224e619) Signed-off-by: Armin Kuster <akuster808@gmail.com>
* gpsd: fix /etc/default/gpsd ALTERNATIVES logicMartin Kelly2018-01-111-3/+2
| | | | | | | | | | | | | | | | | The ALTERNATIVES logic for the /etc/default/gpsd file is broken, specifying ALTERNATIVE_LINK without brackets. In addition, it refers to ALTERNATIVE_PATH, which update-alternatives.bbclass doesn't use. With this patch, /etc/default/gpsd correctly gets a default link pointing to /etc/default/gpsd.default. Currently, no such link gets created, and gpsd starts off disabled by default since it's missing this config file. Signed-off-by: Martin Kelly <mkelly@xevo.com> Signed-off-by: Armin Kuster <akuster808@gmail.com> (cherry picked from commit 194f855b44319c7834ba11e6e0a77ef279970a04) Signed-off-by: Ramon Fried <rfried@codeaurora.org> Signed-off-by: Armin Kuster <akuster808@gmail.com>
* gpsd: Fix gpsd Yocto pyro build for read only rootfsDan Walkes2017-10-151-9/+8
| | | | | | | | | | | | | | | | | | | | | | Attempting to include gpsd on Yocto pyro with IMAGE_FEATURES including read-only-rootfs results in an error: "The following packages could not be configured offline and rootfs is read-only" This stems from a failure during the do_rootfs steps where the /etc/init.d/gpsd file is missing during the call to update-rc.d. This happens because the /etc/init.d/gpsd file is installed during package install for gpsd-conf instead of gpsd, and the default value for INITSCRIPT_PACKAGES is PN. To resolve, specify INITSCRIPT_PACKAGES as gpsd-conf instead. Also, as suggested on the Yocto mailing list, refactor to inherit update-alternatives and use this to replace the postinst and postrm steps. Signed-off-by: Dan Walkes <danwalkes@trellis-logic.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: remove blacklisted recipesMartin Jansa2017-08-311-114/+0
| | | | | | | | * as PNBLACKLIST message says, these recipes are blacklisted for long time and nobody showed any interest to fix them * remove all unused .patch and .inc files as well Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* bluez4: remove bluez4-only recipesMartin Jansa2017-08-1316-477/+0
| | | | | | | | | | | | | | | | | | | | | * remove recipes which support only bluez4 and are blacklisted when bluez5 is selected in DISTRO_FEATURES, if someone is still using bluez4, then it can be restored in separate meta-bluez4 and maintained by people using it. * there are few recipes which support both bluez5 or bluez4 based on selected DISTRO_FEATURES, these can stay in meta-oe repository, but now people without bluez5 in DISTRO_FEATURES will need to add meta-bluez4 layer to satisfy bluez4 dependency meta-gnome/recipes-connectivity/obex/obexd_0.48.bb:DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}" meta-gnome/recipes-gnome/gnome-bluetooth/gnome-bluetooth_3.18.2.bb: ${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)} \ meta-oe/recipes-connectivity/obex/obex-data-server_0.4.6.bb:DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}" meta-oe/recipes-connectivity/obex/openobex_1.7.2.bb:DEPENDS_append_class-target = " ${@bb.utils.contains('DISTRO_FEATURES','bluez5','bluez5','bluez4',d)}" meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb:RDEPENDS_bluez4 = " \ meta-oe/recipes-connectivity/packagegroups/packagegroup-tools-bluetooth.bb:# Install bluez4 tools or bluez5 tools depending on what is specified in the distro. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* proj: update to 4.9.3Marc Ferland2017-07-141-2/+2
| | | | | Signed-off-by: Marc Ferland <ferlandm@amotus.ca> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* orrery: Fix build with hardening flagsKhem Raj2017-07-012-1/+28
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: update to 3.16Max Krummenacher2017-06-1211-281/+9
| | | | | | | | | | | | | | | | | | | 3.16 can be linked with gold, so drop forcing to bfd. Patches: Do not apply and SConstruct dropped these constructs 0001-SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch 0002-SConstruct-remove-rpath.patch Fixed upstream (or plain backports) 0001-Check-for-__STDC_NO_ATOMICS__-before-using-stdatomic.patch 0002-Add-a-test-for-C11-and-check-we-have-C11-before-usin.patch 0003-Whoops-check-for-C11-not-for-not-C11-in-stdatomic.h-.patch 0001-Include-stdatomic.h-only-in-C-mode.patch 0001-libgpsd-core-Fix-issue-with-ACTIVATE-hook-not-being-.patch Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: don't compile with goldMax Krummenacher2017-06-121-0/+2
| | | | | | | | | | | | | | | When linking with gold libgps and libgpsd error out with: | ./libgpsd.so: error: undefined reference to 'atan2' | ./libgpsd.so: error: undefined reference to 'pow' | ./libgpsd.so: error: undefined reference to 'sqrt' | ./libgpsd.so: error: undefined reference to 'sin' | ./libgpsd.so: error: undefined reference to 'cos' | collect2: error: ld returned 1 exit status Using the bfd linker fixes the issue. Signed-off-by: Max Krummenacher <max.krummenacher@toradex.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: add removal date to PNBLACKLIST messagesMartin Jansa2017-04-051-1/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | * based on discussion in pndeprecated thread: https://patchwork.openembedded.org/patch/137573/ update the messages to warn possible users that the recipe will be removed before the end of the next development cycle (before Yocto 2.4 is released). * updated with: sed -i 's/^\(PNBLACKLIST.*".*\)"/\1 - the recipe will be removed on 2017-09-01 unless the issue is fixed"/g' `git grep PNBLACKLIST | sed 's/:.*//g' | sort -u | xargs` * then noticed couple recipes being blacklisted only based on DISTRO_FEATURES, so removed those: meta-networking/recipes-support/lksctp-tools/lksctp-tools_1.0.17.bb meta-oe/recipes-connectivity/bluez/bluez-hcidump_2.5.bb meta-oe/recipes-connectivity/bluez/bluez4_4.101.bb meta-oe/recipes-connectivity/bluez/gst-plugin-bluetooth_4.101.bb meta-oe/recipes-navigation/foxtrotgps/foxtrotgps_1.1.1.bb meta-oe/recipes-navigation/gypsy/gypsy.inc meta-oe/recipes-navigation/navit/navit.inc meta-oe/recipes-support/opensync/libsyncml_0.5.4.bb * if it isn't fixed by this date, it's fair game to be removed whenever someone gets around to i Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* geoclue: unblacklist, modemmanager was fixedMartin Jansa2017-02-221-2/+0
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: blacklist recipes depending on blacklisted recipesMartin Jansa2017-02-131-0/+2
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* geoclue: add missing dependency on gobject-introspection-nativeMartin Jansa2017-02-131-1/+1
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: fix multilib buildNicolas Dechesne2016-12-021-0/+1
| | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | | While testing arm 64/32 multi, the following issue was observed: WARNING: gpsd-3.14-r0 do_package: QA Issue: gpsd: Files/directories were installed but not shipped in any package: /usr/lib/libgpsd.so.22.0 /usr/lib/libgps.so.22 /usr/lib/libgpsd.so.22.0.0 /usr/lib/libgpsd.so.22 /usr/lib/libgps.so.22.0.0 /usr/lib/libgps.so /usr/lib/libgps.so.22.0 /usr/lib/libgpsd.so /usr/lib/pkgconfig /usr/lib/pkgconfig/libgpsd.pc /usr/lib/pkgconfig/libgps.pc Please set FILES such that these items are packaged. Alternatively if they are unneeded, avoid installing them or delete them within do_install. gpsd: 11 installed and not shipped files. [installed-vs-shipped] WARNING: gpsd-3.14-r0 do_package_qa: QA Issue: /usr/bin/cgps contained in package gps-utils requires libgps.so.22()(64bit), but no providers found in RDEPENDS_gps-utils? [file-rdeps] WARNING: gpsd-3.14-r0 do_package_qa: QA Issue: /usr/sbin/gpsdctl contained in package gpsd requires libgps.so.22()(64bit), but no providers found in RDEPENDS_gpsd? [file-rdeps] WARNING: gpsd-3.14-r0 do_package_qa: QA Issue: /usr/bin/gpsctl contained in package gpsd-gpsctl requires libgps.so.22()(64bit), but no providers found in RDEPENDS_gpsd-gpsctl? [file-rdeps] WARNING: gpsd-3.14-r0 do_package_qa: QA Issue: gpsd-dbg: found library in wrong location: /usr/lib/.debug/libgpsd.so.22.0.0 gpsd-dbg: found library in wrong location: /usr/lib/.debug/libgps.so.22.0.0 [libdir] gpsd SConstruct file defaults to using '/lib' suffix, which needs to be overriden in the recipe. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* remove True option to getVar callsJoshua Lock2016-12-021-1/+1
| | | | | | | | | getVar() now defaults to expanding by default, thus remove the True option from getVar() calls with a regex search and replace. Search made with the following regex: getVar ?\(( ?[^,()]*), True\) Signed-off-by: Joshua Lock <joshua.g.lock@intel.com>
* gpsd, mongodb: use PACKAGECONFIG_CONFARGS instead of now empty EXTRA_OECONFMartin Jansa2016-10-211-2/+1
| | | | | | | | | | | | | | | | | | | | | | | | * this will fix mongodb build for x86 http://errors.yoctoproject.org/Errors/Details/90392/ which was failing because of missing --wiredtiger=off in qemux86 builds * also we can drop DISABLE_STATIC, because now it's not leaking through EXTRA_OECONF * it will also resolve again autodetected dependencies on bluez, qt and tcmalloc as shown in bitbake -e output: env.gpsd-before:EXTRA_OESCONS=" sysroot=/OE/build/oe-core/tmp-glibc/sysroots/qemux86 libQgpsmm='false' debug='true' strip='false' chrpath='yes' systemd='true' " env.gpsd-after:EXTRA_OESCONS=" sysroot=/OE/build/oe-core/tmp-glibc/sysroots/qemux86 libQgpsmm='false' debug='true' strip='false' chrpath='yes' systemd='true' bluez='true' qt='no' " env.mongodb-before:EXTRA_OESCONS="--prefix=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0/image/usr LIBPATH=/OE/build/oe-core/tmp-glibc/sysroots/qemux86/usr/lib LINKFLAGS='-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed' \ CXXFLAGS='-O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0=/usr/src/debug/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0 -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/sysroots/x86_64-linux= -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/sysroots/qemux86= -fvisibility-inlines-hidden' \ TARGET_ARCH=i586 --ssl --disable-warnings-as-errors --use-system-pcre --use-system-zlib --js-engine=none --nostrip mongod mongos" env.mongodb-after:EXTRA_OESCONS="--prefix=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0/image/usr LIBPATH=/OE/build/oe-core/tmp-glibc/sysroots/qemux86/usr/lib LINKFLAGS='-Wl,-O1 -Wl,--hash-style=gnu -Wl,--as-needed' \ CXXFLAGS='-O2 -pipe -g -feliminate-unused-debug-types -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/work/i586-oe-linux/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0=/usr/src/debug/mongodb/3.3.0+gitAUTOINC+aacd231be0-r0 -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/sysroots/x86_64-linux= -fdebug-prefix-map=/OE/build/oe-core/tmp-glibc/sysroots/qemux86= -fvisibility-inlines-hidden' \ TARGET_ARCH=i586 --ssl --disable-warnings-as-errors --use-system-pcre --use-system-zlib --js-engine=none --nostrip --use-system-tcmalloc --wiredtiger=off mongod mongos" Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: Fix build with muslKhem Raj2016-09-262-0/+35
| | | | | Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* geoclue: Update to 2.4.4Zeeshan Ali2016-09-153-63/+53
| | | | | | | Also drop redundant and now unusable patch. Signed-off-by: Zeeshan Ali <zeeshan.ali@pelagicore.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* Revert "gpsd, foxtrotgps: blacklist, fails to build with new binutils-2.27"Nicolas Dechesne2016-09-152-5/+1
| | | | | | This reverts commit 8c29023f1fe5881f3e001704eb9e5d398777d4a6. Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: make sure the recipe uses LDFLAGSNicolas Dechesne2016-09-151-0/+2
| | | | | | | | | | | | since commit fa436aeb3242cbfdbbe16d448d45bce8eb5b74fd in OE core, we are seeing GNU_HASH QA failure when building gpsd. Since this commit we default to setting the wrong linker hash style to detect such errors in recipes. gpsd is using scons which does not take LDFLAGS into account, and LDFLAGS need to be passed from the environment, using LINKFLAGS variable. Signed-off-by: Nicolas Dechesne <nicolas.dechesne@linaro.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd, foxtrotgps: blacklist, fails to build with new binutils-2.27Martin Jansa2016-09-052-1/+5
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* meta-oe: remove trailing spacesMartin Jansa2016-08-221-1/+1
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* geoclue: add missing intltool-native dependencyMartin Jansa2016-08-151-7/+7
| | | | | | | | | * fixes: | checking pkg-config is at least version 0.22... yes | ../geoclue-2.0.0/configure: line 16260: syntax error near unexpected token `0.40.0' | ../geoclue-2.0.0/configure: line 16260: `IT_PROG_INTLTOOL(0.40.0)' Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* geos: use std::isnan to support gcc6Derek Straka2016-06-153-6/+24
| | | | | Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* abiword, fbreader, tvheadend, glmark2, libqmi, modemmanager, thrift, wvdial, ↵Martin Jansa2016-06-132-0/+5
| | | | | | wvstreams, dt, collectd, gtkmathview, tcsh, glcompbench, geos, libspatialite, geis, grail, opencv, openwbem, fwts: blacklist, fails to build with gcc-6 or glibc-2.24 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* Remove unnecessary exports of HOST_SYS and BUILD_SYS in python-based recipesAlexander Kanavin2016-06-081-6/+0
| | | | | | | They are no longer required to build python software. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* meta-oe: use bb.utils.contains() instead of base_contains()Ross Burton2016-04-281-2/+2
| | | | | | | | base_contains() is a compatibility wrapper and may warn in the future, so replace all instances with bb.utils.contains(). Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* omgps: remove the recipeAlexander Kanavin2016-03-149-386/+0
| | | | | | | The project is dead upstream, and relies on pygobject 2.x which has been replaced by 3.x in oe.core. Signed-off-by: Alexander Kanavin <alexander.kanavin@linux.intel.com>
* recipes: Replace "cp -a" with "cp -R --no-dereference --preserve=mode,links"Martin Jansa2016-03-041-1/+1
| | | | | | | | | * Using "cp -a" leaks UID of user running the builds, causing many QA warnings. * See this thread for details: http://lists.openembedded.org/pipermail/openembedded-core/2015-November/112904.html Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: Fix build when static libs disabledMaxin B. John2016-03-021-0/+1
| | | | | | | | Fix this build error: SCons Error: no such option: --disable-static Signed-off-by: Maxin B. John <maxin.john@intel.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* orrery: fix host-user-contaminatedYi Zhao2016-01-271-0/+1
| | | | | | | | | Fix QA warning: WARNING: QA Issue: orrery: /orrery/usr/share/orrery/deepSky/messier is owned by uid 1000, which is the same as the user running bitbake. This may be due to host contamination [host-user-contaminated] Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: Add patch to fix broken ACTIVATE hook.Moritz Fischer2016-01-272-0/+36
| | | | | | | | | This patch is already in mainline gpsd. It fixes a bug where the ACTIVATE hook for a device never gets called. Signed-off-by: Moritz Fischer <moritz.fischer@ettus.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* navit: disable qt4 support by defaultMartin Jansa2016-01-141-3/+2
| | | | | | * now with qt4 moved to separate meta-qt4 we shouldn't enable it by default Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gspd: disable qt4 support by defaultMartin Jansa2016-01-141-1/+1
| | | | | | * now with qt4 moved to separate meta-qt4 we shouldn't enable it by default Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* recipes: remove recipes using or depending on qt4 bbclasses or recipesMartin Jansa2016-01-143-47/+0
| | | | | | | | | | | | | * anki is removed because it runtime depends on python-pyqt, other recipes are inheriting one of bbclasses removed from oe-core in: commit cb89d2b25b4edb1241bc5426a69a6bc44df9be2c Author: Alexander Kanavin <alexander.kanavin@linux.intel.com> Date: Fri Nov 27 15:48:20 2015 +0200 qt4: remove recipes and classes * if you're still using one of these recipes add it to meta-qt4 layer Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: also support bluez5Christopher Larson2015-12-181-2/+2
| | | | | | | | gpsd uses libbluetooth, not the dbus interface, so it can work with bluez5 as well, as the library is compatible. Signed-off-by: Christopher Larson <chris_larson@mentor.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gdal: blacklist, fails to build with gcc-5Martin Jansa2015-10-131-0/+5
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: Fix build with gcc-5.2Martin Jansa2015-09-232-0/+44
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* geoclue: add PACKAGECONFIG for geoipMartin Jansa2015-08-311-0/+2
| | | | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: Update to 3.14.Philip Balister2015-05-138-15/+128
| | | | | | | | | | * _NO_ATOMICS patches are from upstream * Update the SConstruct-respect-sysroot-also-in-SPLINTOPTS.patch * Fix some QA warnings * Add PACKAGECONFIG for qt support Signed-off-by: Philip Balister <philip@balister.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* gpsd: fix PN -> BPN for multilibYi Zhao2015-05-131-2/+2
| | | | Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
* orrery: fix PN -> BPN for multilibYi Zhao2015-05-131-1/+1
| | | | | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* omgps: fix PN -> BPN for multilibYi Zhao2015-05-131-1/+1
| | | | | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* navit: fix PN -> BPN for multilibYi Zhao2015-05-132-13/+13
| | | | | Signed-off-by: Yi Zhao <yi.zhao@windriver.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* foxtrotgps: Fix QA warningsArmin Kuster2015-05-111-0/+1
| | | | | | | WARNING: QA Issue: foxtrotgps requires /usr/bin/python, /usr/bin/perl, but no providers in its RDEPENDS [file-rdeps] Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* *obex*, navit, libsyncml, foxtrotgps, gypsy, bluez-hcidump, bluez4, ↵Martin Jansa2015-05-113-0/+7
| | | | | | gst-plugin-bluetooth, gnome-bluetooth: blacklist bluez4 only recipes when bluez5 is in DISTRO_FEATURES foo
* gpsd: select distro preference for bluez providerPeter Bigot2015-02-271-3/+3
| | | | | Signed-off-by: Peter A. Bigot <pab@pabigot.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libspatialite: Upgrade to version 4.2.0Holger Hans Peter Freyther2015-02-124-212/+27
| | | | | | | | | | | | Package the new sqlite3 plugin into a new package and skip the dev-so qa issue. Add some extra depends that are now used by the library. The patch was adapted for meta-openembedded by Henning Heinold, setting the upstream status for the geos-config.patch Signed-off-by: Henning Heinold <henning@itconsulting-heinold.de> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* navit: Fix license format QA errorOtavio Salvador2014-12-311-1/+1
| | | | | | | | | | | | Fix following QA error: ,---- | WARNING: Recipe navit, LICENSE (GPLv2 LGPLv2) has invalid format, | LICENSES must have operator "([&|() ])" between them. `---- Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
* libspatialite: Fix license format QA errorOtavio Salvador2014-12-311-1/+1
| | | | | | | | | | | | | Fix the following QA error: ,---- | WARNING: Recipe libspatialite, LICENSE (MPLv1.1 GPLv2+ LGPLv2.1+) has | invalid format, LICENSES must have operator "([&|() ])" between | them. `---- Signed-off-by: Otavio Salvador <otavio@ossystems.com.br> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>