aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-opie/opie-mediaplayer2
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-05-13 23:58:58 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2012-05-20 22:34:17 +0100
commit1786b04aa2fde02e0b1db4dcd2ff7be54381e8ce (patch)
treeba88dc80edd9c2f2614053065b46794878131ea8 /recipes-opie/opie-mediaplayer2
parenta4791297c8f8ee265337beb3678e5411cabaddf1 (diff)
downloadmeta-opie-1786b04aa2fde02e0b1db4dcd2ff7be54381e8ce.tar.gz
Fix Opie Git recipes to use SRCPV
Using SRCPV we get e.g. 1.2.5+git1+... and the number will increment when OPIE_SRCREV changes, ensuring that the version number doesn't go backwards (although it will once for this change if you have existing packages beforehand, unfortunately). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-opie/opie-mediaplayer2')
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb4
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb4
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb4
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb4
-rw-r--r--recipes-opie/opie-mediaplayer2/opie-mediaplayer2_git.bb4
5 files changed, 10 insertions, 10 deletions
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb
index 7cf0215..8a4bf18 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default-landscape_git.bb
@@ -1,8 +1,8 @@
SKINNAME = "default_landscape"
require opie-mediaplayer2-skin.inc
-PV = "${OPIE_GIT_PV}"
+inherit opie_git
PR = "r4"
-SRC_URI = "${OPIE_GIT};protocol=git;subpath=pics"
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=pics;name=first"
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb
index da74a51..0a974a7 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-default_git.bb
@@ -1,8 +1,8 @@
SKINNAME = "default"
require opie-mediaplayer2-skin.inc
-PV = "${OPIE_GIT_PV}"
+inherit opie_git
PR = "r5"
-SRC_URI = "${OPIE_GIT};protocol=git;subpath=pics"
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=pics;name=first"
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb
index ef9cd63..1bb945b 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-pod_git.bb
@@ -1,8 +1,8 @@
SKINNAME = "Pod"
require opie-mediaplayer2-skin.inc
-PV = "${OPIE_GIT_PV}"
+inherit opie_git
PR = "r4"
-SRC_URI = "${OPIE_GIT};protocol=git;subpath=pics"
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=pics;name=first"
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb
index 9239dfb..c9c1e7a 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2-skin-techno_git.bb
@@ -1,8 +1,8 @@
SKINNAME = "techno"
require opie-mediaplayer2-skin.inc
-PV = "${OPIE_GIT_PV}"
+inherit opie_git
PR = "r4"
-SRC_URI = "${OPIE_GIT};protocol=git;subpath=pics"
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=pics;name=first"
diff --git a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2_git.bb b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2_git.bb
index 812c9c6..ea77369 100644
--- a/recipes-opie/opie-mediaplayer2/opie-mediaplayer2_git.bb
+++ b/recipes-opie/opie-mediaplayer2/opie-mediaplayer2_git.bb
@@ -1,7 +1,7 @@
require ${PN}.inc
-PV = "${OPIE_GIT_PV}"
+inherit opie_git
-SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/multimedia/opieplayer2 \
+SRC_URI = "${OPIE_GIT};protocol=git;subpath=noncore/multimedia/opieplayer2;name=first \
${OPIE_GIT};protocol=git;subpath=pics \
${OPIE_GIT};protocol=git;subpath=apps"