aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qt
diff options
context:
space:
mode:
authorApelete Seketeli <apelete@seketeli.net>2013-04-23 23:48:24 +0200
committerPaul Eggleton <paul.eggleton@linux.intel.com>2013-04-24 23:11:13 +0100
commitc2c4089a61e62822ae4afff1996aa3591f4cdc9e (patch)
tree40c6c4de984eba8639607ad7aff9a238eb1b97d2 /recipes-qt
parentc242efc6ca55772a88602f1f8f94dff697b38430 (diff)
downloadmeta-opie-c2c4089a61e62822ae4afff1996aa3591f4cdc9e.tar.gz
uicmoc: fix compile issue with GCC-4.7
Fix compile issue found when building uicmoc-native with GCC-4.7. Though it was detected with version 4.7, the problem may appear with an earlier version of GCC-4.x. Signed-off-by: Apelete Seketeli <apelete@seketeli.net>
Diffstat (limited to 'recipes-qt')
-rw-r--r--recipes-qt/uicmoc/uicmoc-2.3.10/gcc4.7.patch11
-rw-r--r--recipes-qt/uicmoc/uicmoc_2.3.10.bb1
2 files changed, 12 insertions, 0 deletions
diff --git a/recipes-qt/uicmoc/uicmoc-2.3.10/gcc4.7.patch b/recipes-qt/uicmoc/uicmoc-2.3.10/gcc4.7.patch
new file mode 100644
index 0000000..ad09bfe
--- /dev/null
+++ b/recipes-qt/uicmoc/uicmoc-2.3.10/gcc4.7.patch
@@ -0,0 +1,11 @@
+--- qt-2.3.10/src/tools/qvaluestack.h.orig 2013-04-23 21:04:50.373589050 +0200
++++ qt-2.3.10/src/tools/qvaluestack.h 2013-04-23 21:33:48.857599178 +0200
+@@ -49,7 +49,7 @@
+ public:
+ QValueStack() {}
+ ~QValueStack() {}
+- void push( const T& d ) { append(d); }
++ void push( const T& d ) { this->append(d); }
+ T pop()
+ {
+ T elem( this->last() );
diff --git a/recipes-qt/uicmoc/uicmoc_2.3.10.bb b/recipes-qt/uicmoc/uicmoc_2.3.10.bb
index ca6a7a1..0588436 100644
--- a/recipes-qt/uicmoc/uicmoc_2.3.10.bb
+++ b/recipes-qt/uicmoc/uicmoc_2.3.10.bb
@@ -9,6 +9,7 @@ SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz \
file://gcc3_4.patch \
file://gcc4.patch \
file://gcc4_1.patch \
+ file://gcc4.7.patch \
file://64bit-cleanup.patch \
file://kernel-asm-page.patch"
S = "${WORKDIR}/qt-${PV}"