aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/justreader
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/justreader
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/justreader')
-rw-r--r--recipes-qtopia/justreader/files/correct-settings-path.patch17
-rw-r--r--recipes-qtopia/justreader/files/missing-include.patch10
-rw-r--r--recipes-qtopia/justreader/justreader_2.0k.bb33
3 files changed, 60 insertions, 0 deletions
diff --git a/recipes-qtopia/justreader/files/correct-settings-path.patch b/recipes-qtopia/justreader/files/correct-settings-path.patch
new file mode 100644
index 0000000..695edc1
--- /dev/null
+++ b/recipes-qtopia/justreader/files/correct-settings-path.patch
@@ -0,0 +1,17 @@
+upstream: http://sf.net/tracker/?func=detail&aid=1115394&group_id=61928&atid=498857
+
+#
+# Patch managed by http://www.holgerschurig.de/patcher.html
+#
+
+--- TextReader2/qpex/config.cpp~correct-settings-path
++++ TextReader2/qpex/config.cpp
+@@ -109,7 +109,7 @@
+ case User: {
+ QString homeDirPath = QDir::homeDirPath();
+
+- QDir dir = (homeDirPath + "/Choices/common");
++ QDir dir = (homeDirPath + "/Settings");
+ if ( !dir.exists() )
+ #ifndef Q_OS_WIN32
+ mkdir(dir.path().local8Bit(),0700);
diff --git a/recipes-qtopia/justreader/files/missing-include.patch b/recipes-qtopia/justreader/files/missing-include.patch
new file mode 100644
index 0000000..4831f38
--- /dev/null
+++ b/recipes-qtopia/justreader/files/missing-include.patch
@@ -0,0 +1,10 @@
+--- a/shcm.cpp 2009-05-25 09:07:19.928704817 +0200
++++ b/shcm.cpp 2009-05-25 09:07:38.225747505 +0200
+@@ -19,6 +19,7 @@
+ ****************************************************************************/
+
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <vector>
+
+ #include "shcm.h"
diff --git a/recipes-qtopia/justreader/justreader_2.0k.bb b/recipes-qtopia/justreader/justreader_2.0k.bb
new file mode 100644
index 0000000..9df89fa
--- /dev/null
+++ b/recipes-qtopia/justreader/justreader_2.0k.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "An E-Books reader for Qt/Embedded based Palmtop Environments"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://justreader.sourceforge.net/"
+PR = "r3"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/justreader/justreader_${PV}.tgz \
+file://correct-settings-path.patch \
+file://missing-include.patch"
+
+S = "${WORKDIR}/TextReader2"
+
+inherit palmtop
+
+EXTRA_QMAKEVARS_POST += 'INCLUDEPATH+="${STAGING_INCDIR}/qpe" LIBS+=-lqpe'
+export OE_QMAKE_LINK="${CXX}"
+
+do_configure_prepend() {
+ find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/pics/${PN}/ \
+ ${D}${palmtopdir}/apps/Applications
+ install -m 0644 apps/Applications/justreader.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0755 bin/justreader ${D}${palmtopdir}/bin/
+ install -m 0644 pics/* ${D}${palmtopdir}/pics/justreader/
+}
+
+SRC_URI[md5sum] = "74b2b89b12668cbbbb093b6343e9f52d"
+SRC_URI[sha256sum] = "55b0dd7ac3f9860a4cba0797213fdaa898b77f3228612e3499d54e6fe6144514"