aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/mileage
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/mileage
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/mileage')
-rw-r--r--recipes-qtopia/mileage/mileage_cvs.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/recipes-qtopia/mileage/mileage_cvs.bb b/recipes-qtopia/mileage/mileage_cvs.bb
new file mode 100644
index 0000000..2331ded
--- /dev/null
+++ b/recipes-qtopia/mileage/mileage_cvs.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "A Car Mileage Calculator."
+HOMEPAGE = "http://mileage.sourceforge.net"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+LICENSE = "GPL"
+#Change to form x.y.z+cvs${SRCDATE} when 4.2.0 changes in PV
+SRCDATE = "20060814"
+PV = "4.2.0-cvs-${SRCDATE}"
+PR = "r2"
+
+SRC_URI = "cvs://anonymous@mileage.cvs.sourceforge.net/cvsroot/mileage;module=mileage"
+S = "${WORKDIR}/mileage"
+
+inherit palmtop
+export OE_QMAKE_LINK="${CXX}"
+
+do_install() {
+ install -d ${D}${palmtopdir}/apps/Applications/
+ install -d ${D}${palmtopdir}/pics/
+ install -d ${D}${palmtopdir}/bin/
+ install -m 0755 ${PN} ${D}${palmtopdir}/bin/
+ install -m 0644 ${PN}.desktop ${D}${palmtopdir}/apps/Applications/
+ install -m 0644 ${PN}.png ${D}${palmtopdir}/pics/
+#FIXME: Package and install help files seperatly
+}
+