aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/nunome
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/nunome
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/nunome')
-rw-r--r--recipes-qtopia/nunome/files/nunome.patch197
-rw-r--r--recipes-qtopia/nunome/files/timer.patch21
-rw-r--r--recipes-qtopia/nunome/nunome_1.0.2.bb47
3 files changed, 265 insertions, 0 deletions
diff --git a/recipes-qtopia/nunome/files/nunome.patch b/recipes-qtopia/nunome/files/nunome.patch
new file mode 100644
index 0000000..450e160
--- /dev/null
+++ b/recipes-qtopia/nunome/files/nunome.patch
@@ -0,0 +1,197 @@
+# Signed off by Michael 'Mickey' Lauer <mickey@Vanille.de>
+--- nunome/dicman/nnmDicman.cpp~nunome.patch
++++ nunome/dicman/nnmDicman.cpp
+@@ -1,75 +1,4 @@
+-/*
+- $Id: nnmDicman.cpp,v 1.1.1.1 2005/06/29 22:24:22 leggewie Exp $
+-
+- Copyright (C) 2001-2002 AXE,Inc. <sg@axe-inc.co.jp>
+-
+- This file is part of Nunome-Qtopia.
+-
+- Nunome-Qtopia is free software; you can redistribute it and/or modify it
+- under the terms of the GNU General Public License as published by
+- the Free Software Foundation; either version 2, or (at your option)
+- any later version.
+-
+- Nunome-Qtopia is distributed in the hope that it will be useful, but
+- WITHOUT ANY WARRANTY; without even the implied warranty of
+- MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+- GNU General Public License for more details.
+-
+- You should have received a copy of the GNU General Public License
+- along with Nunome; see the file COPYING. If not, write to
+- the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
+-
+-/* Dictinary maintenance tool */
+-
+-#include <qpeapplication.h>
+-#include <qlabel.h>
+-#include <qpainter.h>
+-#include <qpixmap.h>
+-#include <qwidget.h>
+-#include <qlayout.h>
+-#include <qpushbutton.h>
+-#include <qlineedit.h>
+-
+-#include <stdio.h>
+-#include <stdlib.h>
+-#include <unistd.h>
+-#include <sys/types.h>
+-#include <signal.h>
+-
+-extern "C" {
+-#include "Nnm.h"
+-#include "NnmFeature.h"
+-#include "nnmStub.h"
+-#include "NnmProto.h"
+-}
+-#include "nnmCanvas.h"
+-
+-class uiWidget : public QWidget
+-{
+-Q_OBJECT
+-
+-public:
+- uiWidget( QWidget *parent = 0, const char *name = 0, WFlags f=0 );
+-
+- int serverPID;
+- char *dictionaryPath;
+-
+-private slots:
+- void regist( void );
+- void clear( void );
+- void quit( void );
+-
+- void format( const QString & );
+-
+-private:
+- nnmCanvas *canvas;
+- QLineEdit *input;
+- ulong code;
+-
+- void updateDictionary( void );
+-};
+-
+-#include "moc_nnmDicman.cpp"
++#include "nnmDicman.h"
+
+ uiWidget::uiWidget( QWidget *parent, const char *name, WFlags f )
+ : QWidget( parent, name, f )
+--- nunome/ui/nunome.cpp~nunome.patch
++++ nunome/ui/nunome.cpp
+@@ -22,7 +22,7 @@
+
+ /* Nunome input-method */
+
+-#include <qpeapplication.h>
++#include <qpe/qpeapplication.h>
+ #include <qpainter.h>
+ #include <qpixmap.h>
+ #include <qwidget.h>
+--- nunome/ui/nunome.h~nunome.patch
++++ nunome/ui/nunome.h
+@@ -32,14 +32,14 @@
+ #include "nnmSelect.h"
+ #include "nnmSymbol.h"
+
+-#define PARAMETER_FILE_PATH "/usr/local/share/nunome/.nunome"
++#define PARAMETER_FILE_PATH "/opt/QtPalmtop/share/nunome/.nunome"
+
+-#define DEFAULT_SYSTEM_DICTIONARY "/usr/local/share/nunome/nunome_uni.dic"
+-#define DEFAULT_USER_DICTIONARY "/usr/local/share/nunome/user.dic"
++#define DEFAULT_SYSTEM_DICTIONARY "/opt/QtPalmtop/share/nunome/nunome_uni.dic"
++#define DEFAULT_USER_DICTIONARY "/opt/QtPalmtop/share/nunome/user.dic"
+ #define DEFAULT_TIMEOUT_MSEC 500
+ #define DEFAULT_LEARN_FLAG true
+-#define DEFAULT_SERVER_PROGRAM_PATH "/usr/local/share/nunome/nnmsrv"
+-#define DEFAULT_LEARN_PROGRAM_PATH "/usr/local/share/nunome/nnmDicman"
++#define DEFAULT_SERVER_PROGRAM_PATH "/opt/QtPalmtop/bin/nnmsrv"
++#define DEFAULT_LEARN_PROGRAM_PATH "/opt/QtPalmtop/bin/nnmDicman"
+
+ class nnmParameter
+ {
+--- nunome/ui/nunomeImpl.h~nunome.patch
++++ nunome/ui/nunomeImpl.h
+@@ -23,7 +23,7 @@
+ #ifndef NUNOMEIMPL_H
+ #define NUNOMEIMPL_H
+
+-#include <inputmethodinterface.h>
++#include <qpe/inputmethodinterface.h>
+
+ class Nunome;
+ class QPixmap;
+--- /dev/null
++++ nunome/dicman/nnmDicman.h
+@@ -0,0 +1,70 @@
++/*
++ $Id: nnmDicman.cpp,v 1.1.1.1 2005/06/29 22:24:22 leggewie Exp $
++
++ Copyright (C) 2001-2002 AXE,Inc. <sg@axe-inc.co.jp>
++
++ This file is part of Nunome-Qtopia.
++
++ Nunome-Qtopia is free software; you can redistribute it and/or modify it
++ under the terms of the GNU General Public License as published by
++ the Free Software Foundation; either version 2, or (at your option)
++ any later version.
++
++ Nunome-Qtopia is distributed in the hope that it will be useful, but
++ WITHOUT ANY WARRANTY; without even the implied warranty of
++ MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
++ GNU General Public License for more details.
++
++ You should have received a copy of the GNU General Public License
++ along with Nunome; see the file COPYING. If not, write to
++ the Free Software Foundation, 675 Mass Ave, Cambridge, MA 02139, USA. */
++
++/* Dictinary maintenance tool */
++
++#include <qpe/qpeapplication.h>
++#include <qlabel.h>
++#include <qpainter.h>
++#include <qpixmap.h>
++#include <qwidget.h>
++#include <qlayout.h>
++#include <qpushbutton.h>
++#include <qlineedit.h>
++
++#include <stdio.h>
++#include <stdlib.h>
++#include <unistd.h>
++#include <sys/types.h>
++#include <signal.h>
++
++extern "C" {
++#include "Nnm.h"
++#include "NnmFeature.h"
++#include "nnmStub.h"
++#include "NnmProto.h"
++}
++#include "nnmCanvas.h"
++
++class uiWidget : public QWidget
++{
++Q_OBJECT
++
++public:
++ uiWidget( QWidget *parent = 0, const char *name = 0, WFlags f=0 );
++
++ int serverPID;
++ char *dictionaryPath;
++
++private slots:
++ void regist( void );
++ void clear( void );
++ void quit( void );
++
++ void format( const QString & );
++
++private:
++ nnmCanvas *canvas;
++ QLineEdit *input;
++ ulong code;
++
++ void updateDictionary( void );
++};
diff --git a/recipes-qtopia/nunome/files/timer.patch b/recipes-qtopia/nunome/files/timer.patch
new file mode 100644
index 0000000..ccd6564
--- /dev/null
+++ b/recipes-qtopia/nunome/files/timer.patch
@@ -0,0 +1,21 @@
+diff --git a/ui/nnmCanvas.cpp b/ui/nnmCanvas.cpp
+index a548ddf..3b8e7d4 100755
+--- a/ui/nnmCanvas.cpp
++++ b/ui/nnmCanvas.cpp
+@@ -35,7 +35,7 @@
+
+ nnmCanvas::nnmCanvas( QWidget *parent, int timeoutParam, int initID,
+ const char *name, WFlags f )
+- : QWidget( parent, name, f )
++ : QWidget( parent, name, f ), timer(0)
+ {
+ setFixedSize( NnmCANVAS_DISPLAY_SIZE, NnmCANVAS_DISPLAY_SIZE );
+ init();
+@@ -149,7 +149,7 @@ void nnmCanvas::resizeEvent( QResizeEvent *event )
+
+ void nnmCanvas::init( void )
+ {
+- if ( timeoutMsec > 0 && timer->isActive() ) {
++ if ( timeoutMsec > 0 && timer && timer->isActive() ) {
+ timer->stop();
+ } \ No newline at end of file
diff --git a/recipes-qtopia/nunome/nunome_1.0.2.bb b/recipes-qtopia/nunome/nunome_1.0.2.bb
new file mode 100644
index 0000000..2429a2b
--- /dev/null
+++ b/recipes-qtopia/nunome/nunome_1.0.2.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "Japanese input method plugin"
+HOMEPAGE = "http://www.sikigami.com/nunome-Qtopia-1.0/"
+SECTION = "opie/inputmethods"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS_${PN} = "virtual-japanese-font"
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/gakusei/nunome-${PV}.tar.bz2 \
+ file://timer.patch \
+ file://nunome.patch"
+S = "${WORKDIR}/nunome"
+
+inherit opie
+
+EXTRA_QMAKEVARS_POST += "INCLUDEPATH+=${S}/Nnmlib INCLUDEPATH+=${S}/ui LIBS+=-L${S}"
+OE_QMAKE_CXXFLAGS := "${@oe_filter_out('-fno-rtti', '${OE_QMAKE_CXXFLAGS}', d)}"
+PARALLEL_MAKE = ""
+
+do_configure_prepend() {
+ sed -i -e 's,/opt/QtPalmtop/bin/,${bindir}/,g' "${S}/ui/nunome.h"
+ sed -i -e 's,/opt/QtPalmtop/,${palmtopdir}/,g' "${S}/ui/nunome.h"
+ printf "TEMPLATE=subdirs\nSUBDIRS=Nnmlib server ui dicman ui\n" >nunome.pro
+ cd Nnmlib && qmake -project -t lib && cd ../
+ cd server && qmake -project && printf "LIBS+=-lNnmlib\nTARGET=server.bin\n" >> server.pro && cd ../
+ cd dicman && qmake -project && printf "LIBS+=-lnunome -lNnmlib\nTARGET=dicman.bin\n" >> dicman.pro && cd ../
+ cd ui && qmake -project -t lib && printf "LIBS+=-lNnmlib\nTARGET=nunome\n" >> ui.pro && cd ../
+ find . -name "moc*"|xargs rm -f
+ find . -name "Makefile"|xargs rm -f
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/lib
+ install -d ${D}${bindir}
+ install -d ${D}${palmtopdir}/i18n/ja
+ install -d ${D}${palmtopdir}/share/nunome
+
+ oe_libinstall -so libNnmlib ${D}${palmtopdir}/lib
+ install -m 644 nunome_uni.dic ${D}${palmtopdir}/share/nunome
+ install -m 755 server.bin ${D}${bindir}/nnmsrv
+ install -m 755 dicman.bin ${D}${bindir}/nnmDicman
+ install -m 644 ui/nunome.qm ${D}${palmtopdir}/i18n/ja
+ install -m 644 dicman/nnmDicman.qm ${D}${palmtopdir}/i18n/ja
+}
+
+SRC_URI[md5sum] = "e5c9d2351de250aaa7abf581a1f2c0f4"
+SRC_URI[sha256sum] = "7bda9302036facd65b323d7042a809b08d55d5b61b38d4d40f22f41f27fec83c"