aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/powermanga/powermanga_0.79.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/powermanga/powermanga_0.79.bb
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/powermanga/powermanga_0.79.bb')
-rw-r--r--recipes-qtopia/powermanga/powermanga_0.79.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/recipes-qtopia/powermanga/powermanga_0.79.bb b/recipes-qtopia/powermanga/powermanga_0.79.bb
new file mode 100644
index 0000000..579ed90
--- /dev/null
+++ b/recipes-qtopia/powermanga/powermanga_0.79.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "Powermanga is an arcade 2D shoot-em-up game with 41 levels and more than 200 sprites."
+SECTION = "opie/games"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "libsdl-qpe libsdl-mixer"
+PR = "r1"
+
+SRC_URI = "http://linux.tlk.fr/games/Powermanga/download/powermanga-0.79.tgz \
+ file://linuxroutines.cpp \
+ file://pda-tweaks.patch \
+ file://powermanga.pro \
+ file://powermanga.png \
+ file://powermanga.desktop"
+
+S = "${WORKDIR}/${PN}-${PV}/"
+
+inherit palmtop
+
+do_configure_prepend() {
+ mv ${WORKDIR}/linuxroutines.cpp ${S}/src/
+ mv ${WORKDIR}/powermanga.pro ${S}/
+ rm -f `find ${S}/ -name Makefile\*`
+ rm -f `find ${S}/ -name config\*`
+}
+
+do_install() {
+ install -d ${D}${palmtopdir}/bin \
+ ${D}${palmtopdir}/pics \
+ ${D}${palmtopdir}/apps/Games \
+ ${D}${palmtopdir}/share/games/powermanga/graphics \
+ ${D}${palmtopdir}/share/games/powermanga/sounds
+ install -m 0755 ${S}/src/powermanga ${D}${palmtopdir}/bin/powermanga
+ install -m 0644 ${WORKDIR}/powermanga.png ${D}${palmtopdir}/pics/powermanga.png
+ install -m 0644 ${WORKDIR}/powermanga.desktop ${D}${palmtopdir}/apps/Games/powermanga.desktop
+ install -m 0644 ${S}/graphics/* ${D}${palmtopdir}/share/games/powermanga/graphics/
+ install -m 0644 ${S}/sounds/* ${D}${palmtopdir}/share/games/powermanga/sounds/
+}
+
+SRC_URI[md5sum] = "3a4f00658496921b7327413ac476c1b7"
+SRC_URI[sha256sum] = "99a9737480224be47362387d2d2389bee61d7685510b3a161b2b1db6c0556c26"