aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/qmatrix/qmatrix_1.1.0.bb
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-21 20:46:57 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-08-21 20:51:42 +0100
commitf2d3bbdd89a3db99b70830c3bf13d1d741609e78 (patch)
treed9632070caef8c33cca03eaa3a0b009512b2c5a2 /recipes-qtopia/qmatrix/qmatrix_1.1.0.bb
parent43642beb6334c0bb6d9492ae7d79d4dbe266a8ed (diff)
downloadmeta-opie-f2d3bbdd89a3db99b70830c3bf13d1d741609e78.tar.gz
qmatrix: fix build on non-ia32 systems
A tools/bin2c 32-bit x86 executable was being shipped and used during the build, which does not work on other architectures (e.g. x86-64). Deleting the file ensures the executable itself is built during the build process. (Also remove some irrelevant stuff clearly left over from copy-pasting from the qfish2 recipe.) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/qmatrix/qmatrix_1.1.0.bb')
-rw-r--r--recipes-qtopia/qmatrix/qmatrix_1.1.0.bb12
1 files changed, 4 insertions, 8 deletions
diff --git a/recipes-qtopia/qmatrix/qmatrix_1.1.0.bb b/recipes-qtopia/qmatrix/qmatrix_1.1.0.bb
index dfcfe1f..ef79615 100644
--- a/recipes-qtopia/qmatrix/qmatrix_1.1.0.bb
+++ b/recipes-qtopia/qmatrix/qmatrix_1.1.0.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "A matrix Game, Qt/Embedded based Palmtop Environments Edition"
SECTION = "opie/games"
LICENSE = "GPL"
-PR = "r2"
+PR = "r3"
SRC_URI = "http://www.geocities.co.jp/SiliconValley-Oakland/8074/src/qmatrix-${PV}.tar.gz"
S = "${WORKDIR}/qmatrix"
@@ -15,16 +15,12 @@ MACHTYPE_tosa = "sl700"
do_configure_append() {
ln -v -f -s config/config-${MACHTYPE}.h config.h
ln -v -f -s config/config.mk-${MACHTYPE} config.mk
- if [ "${MACHTYPE}" = "sl300" ]
- then
- ln -vfs bigFishSize.h areaSize.h
- else
- ln -vfs smallFishSize.h areaSize.h
- fi
- ln -v -f -s HiScoreRegConfig-${MACHTYPE}.h HiScoreRegConfig.h
}
do_compile_prepend() {
+ # This binary gets shipped, but should actually be built during compilation
+ rm -f tools/bin2c
+
cd images && oe_runmake && cd ${S}
}