aboutsummaryrefslogtreecommitdiffstats
path: root/recipes-qtopia/subapplet
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-24 17:57:24 +0100
committerPaul Eggleton <paul.eggleton@linux.intel.com>2011-07-30 02:35:12 +0100
commite9b45ff67d32fdc27950a51135b6dabada8334e7 (patch)
treede99cd760c8292ee1dd334e23e1e5cc43e90dfbd /recipes-qtopia/subapplet
downloadmeta-opie-e9b45ff67d32fdc27950a51135b6dabada8334e7.tar.gz
initial commit of meta-opie
Populate the repository with files from OpenEmbedded at revision 45edf621296daf150c72b876d720861235e5762e - no changes, only rearranged the directory structure to match the new oe-core style and added COPYING.MIT and README. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com>
Diffstat (limited to 'recipes-qtopia/subapplet')
-rw-r--r--recipes-qtopia/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch11
-rw-r--r--recipes-qtopia/subapplet/subapplet_1.0.8.bb42
2 files changed, 53 insertions, 0 deletions
diff --git a/recipes-qtopia/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch b/recipes-qtopia/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch
new file mode 100644
index 0000000..fede3c7
--- /dev/null
+++ b/recipes-qtopia/subapplet/subapplet-1.0.8/toolbar-resize-fix.patch
@@ -0,0 +1,11 @@
+--- SubApplet-1.0.8/subapplet.cpp.orig 2004-05-04 00:26:22 +0200
++++ SubApplet-1.0.8/subapplet.cpp 2004-12-22 10:11:52 +0100
+@@ -115,6 +115,8 @@
+ setToggleType(QButton::Toggle);
+ setOnIconSet(QIconSet(mPixmapOpen, QIconSet::Small));
+ setOffIconSet(QIconSet(mPixmapClosed, QIconSet::Small));
++ setFixedWidth(mPixmapOpen.width());
++ setFixedHeight(mPixmapOpen.height());
+ setOn(false);
+ setDown(false);
+ setAutoRaise(mUseFlatButton);
diff --git a/recipes-qtopia/subapplet/subapplet_1.0.8.bb b/recipes-qtopia/subapplet/subapplet_1.0.8.bb
new file mode 100644
index 0000000..3ebed9b
--- /dev/null
+++ b/recipes-qtopia/subapplet/subapplet_1.0.8.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "Applet for the Qtopia environment taskbar that provides an extension panel \
+for the taskbar that let's you load lot's of applet's without taking up space \
+in the normal taskbar."
+SECTION = "opie/applets"
+PRIORITY = "optional"
+LICENSE = "GPL"
+HOMEPAGE = "http://sourceforge.net/projects/subapplet/"
+PR = "r7"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/subapplet/subapplet-1.0.8.tar.gz \
+ file://toolbar-resize-fix.patch"
+
+S = "${WORKDIR}/SubApplet-1.0.8"
+
+inherit palmtop
+
+QMAKE_PROFILES = "subapplet.pro"
+
+do_install() {
+ install -d ${D}${palmtopdir}/plugins/applets ${D}${palmtopdir}/pics/subapplet/
+ install -m 0644 *.png ${D}${palmtopdir}/pics/subapplet/
+ oe_libinstall -so -C rel/opt/QtPalmtop/plugins/applets libsubapplet ${D}${palmtopdir}/plugins/applets/
+}
+
+pkg_postinst() {
+#!/bin/sh
+if pidof -s qpe >/dev/null; then
+ /usr/bin/qcop QPE/TaskBar "reloadApplets()"
+else
+ exit 0
+fi
+ if [ -n "$D" ]; then false; fi
+}
+
+pkg_postrm() {
+#!/bin/sh
+/usr/bin/qcop QPE/TaskBar "reloadApplets()"
+ if [ -n "$D" ]; then false; fi
+}
+
+SRC_URI[md5sum] = "6042daa703d8bd34174b195843e7ffaa"
+SRC_URI[sha256sum] = "4cc4cc703bcd4da0df25e7b87b082bd9d1c836868bc4641b3c960931582dc3d2"